hdu3294---Girls' research

Problem Description
One day, sailormoon girls are so delighted that they intend to research about palindromic strings. Operation contains two steps:
First step: girls will write a long string (only contains lower case) on the paper. For example, "abcde", but 'a' inside is not the real 'a', that means if we define the 'b' is the real 'a', then we can infer that 'c' is the real 'b', 'd' is the real 'c' ……, 'a' is the real 'z'. According to this, string "abcde" changes to "bcdef".
Second step: girls will find out the longest palindromic string in the given string, the length of palindromic string must be equal or more than 2.
 

Input
Input contains multiple cases.
Each case contains two parts, a character and a string, they are separated by one space, the character representing the real 'a' is and the length of the string will not exceed 200000.All input must be lowercase.
If the length of string is len, it is marked from 0 to len-1.
 

Output
Please execute the operation following the two steps.
If you find one, output the start position and end position of palindromic string in a line, next line output the real palindromic string, or output "No solution!".
If there are several answers available, please choose the string which first appears.
 

Sample Input
  
  
b babd a abcd
 

Sample Output
  
  
0 2 aza No solution!
题目大意:输入多组一个字符和一串字符,仅由小写字母组成

例如 c abcba,c代表把串中的c改成a,d改成b... b改成z,a改成y...

求最长回文子串,输出起始和终止下标,并输出回文子串,回文串长度是1输出No

代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
#define N 200009
char s[N],t[N<<1];
int p[N<<1];
int main()
{
    char c;
    int j,i;
    while(~scanf(" %c",&c))
    {
        scanf("%s",s);
        int n=c-'a';
        int len=strlen(s);
        for(i=0; i<len; i++)
        {
            s[i]=s[i]-n;
            if(s[i]<'a')
                s[i]=s[i]+26;
        }
        for(i=1; i<=len; i++)
            t[i*2]=s[i-1],t[2*i+1]='#';
        t[0]='!',t[1]='#';
        len=2*len+1;
        t[len+1]='\0';
        int id=0,mx=0,ans=0,l,r;
        for(i=1; i<=len; i++)
        {
            if(mx>i) p[i]=min(p[2*id-i],mx-i);
            else p[i]=1;
            while(t[i-p[i]]==t[i+p[i]]) p[i]++;
            if(i+p[i]>mx) mx=i+p[i],id=i;
            if(ans<p[i])
            {
                l=(i-p[i])/2;//起始位置
                r=l+p[i]-2;//终止位置
                ans=p[i];//如果写ans=p[i]-1则此if判断条件和下方if判断条件都需改
            }
        }
        if(ans==2)
            puts("No solution!");
        else
        {
            printf("%d %d\n",l,r);
            for(j=l; j<=r; j++)
                cout<<s[j];
            cout<<endl;
        }
    }
    return 0;
}

  
  
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值