【poj3254-Corn Fields】状压DP

Corn Fields
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 17593 Accepted: 9272

Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input

Line 1: Two space-separated integers:  M and  N 
Lines 2.. M+1: Line  i+1 describes row  i of the pasture with  N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

Sample Input

2 3
1 1 1
0 1 0

Sample Output

9

Hint

Number the squares as follows:
1 2 3
  4  

There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.



【题意】

给定一个矩阵,仅有0 1组成, 0代表不能放, 1代表可以放, 要求放的时候上下左右不能相邻, 求一共有几种放法(全不放也算一种)


【思路】

m, n <= 12, 可以用状压DP, dp[i][j]代表前i行的放法数,j是第i行的合法状态(能放并且左右不相邻)。
dp[i][j] = sum(dp[i-1][k]),k是第i-1行的合法状态,并且k和j也要满足上下不相邻,即k&j = 0
dp[1][j]初始化,j合法为1,不合法为0
最后的ans = sum(dp[n][j])

【代码】

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
typedef long long LL;
const LL mod = 100000000;
LL dp[15][(1<<12)+4], a[15][15], b[(1<<12)+4], m;//b数组保存合法的状态
bool yes(int k, int n)//判断n状态是否合法(k记录行数)即能放和左右不相邻
{
    if(n & n<<1) return 0;//左右相邻,不合法
    for(int i = m; i>=1; i--)
    {
        if(a[k][i] == 0 && ((1&n) == 1))//地图上为0但是对应状态这个数为1,不合法
            return 0;
        n >>= 1;
    }
    return 1;
}
int main()
{
    LL n, i, j, k;
    cin>>n>>m;
    for(i = 1; i<=n; i++)
        for(j = 1; j<=m; j++)
            scanf("%lld", &a[i][j]);
    int cnt;
    for(j = 1; j<=n; j++)
    {
        cnt = 0;
        for(i = 0; i<1<<m; i++)
            if(yes(j, i)) b[cnt++] = i;
        if(j == 1)//第一行初始化
            for(i = 0; i<cnt; i++)
                dp[j][b[i]] = 1;
        else
            for(i = 0; i<cnt; i++)
                for(k = 0; k<1<<m; k++)//枚举上一行的所有状态
                    if(yes(j-1, k) && (b[i] & k) == 0)//上一行所有状态合法 、上下不相邻
                        dp[j][b[i]] = (dp[j][b[i]]+dp[j-1][k]) % mod;
    }
    LL ans = 0;
    for(i = 0; i<cnt; i++)
        ans = (ans + dp[n][b[i]]) % mod;
    printf("%lld\n", ans);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值