hdu 5974 A Simple Math Problem

Problem Description
Given two positive integers a and b,find suitable X and Y to meet the conditions:
                                                        X+Y=a
                                              Least Common Multiple (X, Y) =b
 

Input
Input includes multiple sets of test data.Each test data occupies one line,including two positive integers a(1≤a≤2*10^4),b(1≤b≤10^9),and their meanings are shown in the description.Contains most of the 12W test cases.
 

Output
For each set of input data,output a line of two integers,representing X, Y.If you cannot find such X and Y,output one line of "No Solution"(without quotation).
 

Sample Input
  
  
6 8 798 10780
 

Sample Output
  
  
No Solution 308 490
思路:
由题意可知:
                     lcm(x,y)=b;
因为             x*y =gcd(x,y)*lcm(x,y);
所以             x*y =gcd(x,y)*b;
因为             gcd(a,b)=gcd(x,y);
所以             x*y=b*gcd(a,b);
联立             x+y=a;

解个方程就行 ;
#include <cstdio>
#include <cstring>
#include <cmath>

int gcd (int m,int n){
	int flag;
	while(n>0){
		flag=m%n;
		m=n;
		n=flag;
	}
	return m;
}


int main (){
	int a,b;
	while(scanf("%d%d",&a,&b)!=EOF){
		int i,j;
		int c=gcd(a,b);
		int x,y;

		int delta= a*a-4*b*c;
		if(delta<0){
			printf("No Solution\n");
			continue;
		}
		int flag= sqrt(delta);
		if(flag*flag!=delta||(a-flag)%2!=0){
			printf("No Solution\n");
			continue;
		}

		x=(1*a-sqrt(delta))/2;
		y=a-x;

		printf("%d %d\n",x<y?x:y,x<y?y:x);

	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值