数论-HDU5974

A Simple Math Problem
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)

Problem Description
Given two positive integers a and b,find suitable X and Y to meet the conditions:
X+Y=a
Least Common Multiple (X, Y) =b

Input
Input includes multiple sets of test data.Each test data occupies one line,including two positive integers a(1≤a≤2*10^4),b(1≤b≤10^9),and their meanings are shown in the description.Contains most of the 12W test cases.

Output
For each set of input data,output a line of two integers,representing X, Y.If you cannot find such X and Y,output one line of “No Solution”(without quotation).

Sample Input
6 8
798 10780

Sample Output
No Solution
308 490

题意:给你a和b,找到一对x和y使得x+y==a,lcm(x,y)==b。

关键点:根据公式进行推导,最终得到化简后的式子

题解:
假设gcd(x,y)=l

i*l+j*l==a
i*j*l==b
因为i和j此时互质
所以 i+j 和 i*j 也互质
所以gcd(a,b)==l==gcd(x,y)
联立
i+j=a/l
i*j=b/l

#include <bits/stdc++.h>
#define ll long long
using namespace std;
ll a,b;
int main()
{

    while(~scanf("%I64d %I64d",&a,&b))
    {
        ll l=__gcd(a,b);
        a=a/l;
        b=b/l;
        if(a*a-4*b<0)
            printf("No Solution\n");
        else
        {
            ll s=(a-sqrt(a*a-4*b))/2;
            if(s*(a-s)==b)
                printf("%I64d %I64d\n",s*l,(a-s)*l);//最后要乘l
            else
                printf("No Solution\n");
        }
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值