HDU-5974-A Simple Math Problem

Problem Description

Given two positive integers a and b,find suitable X and Y to meet the conditions:
X+Y=a
Least Common Multiple (X, Y) =b

Input

Input includes multiple sets of test data.Each test data occupies one line,including two positive integers a(1≤a≤2*10^4),b(1≤b≤10^9),and their meanings are shown in the description.Contains most of the 12W test cases.

Output

For each set of input data,output a line of two integers,representing X, Y.If you cannot find such X and Y,output one line of “No Solution”(without quotation).

Sample Input

6 8
798 10780

Sample Output

No Solution
308 490

题意:
已知 a,b,找出一个x 和 y 满足 x+y=a,Lcm(x,y)=b;

思路(上网查找):
看数据范围肯定不能进行暴力枚举了!
令gcd(x,y) = g;
那么
g * k1 = x;
g * k2 = y;
因为g 是最大公约数,那么k1与k2 必互质!
=> g*k1*k2 = b
=> g*k1 + g * k2 = a;
所以k1 * k2 = b / g;
k1 + k2 = a/g;
因为k1与k2 互质!
所以k1 * k2 和 k1 + k2 也一定互质(一个新学的知识点= = )
所以a/g 与b/g也互质!
那么g 就是gcd(a,b);
所以我们得出一个结论: gcd(x,y) == gcd(a,b);;
所以x + y 与 x * y都是已知的了,解一元二次方程即可!

因为 gcd(a,b) * lcm(a,b) = a*b;
所以 lcm(a,b) = a/gcd(a,b)*b;
所以题目条件可化为一个一元二次方程:x*x-a*x+b*gcd(a,b)。

代码
#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
using namespace std;
int a,b;
int gcd(int m,int n)
{
    if(n == 0)
        return m;
    else
        return gcd(n,m%n);
}
int main()
{
    int m,p,l;
    int q;
    int x1,x2;
    int flag;
    while(scanf("%d%d",&a,&b)!=EOF)
    {
        flag = 1;
        m = gcd(a,b);
        p = a*a-4*b*m;  //解一元二次方程
        if(p < 0)  //无解
        {
            printf("No Solution\n");
            continue;
        }
        q = (int)sqrt(p);
        if(q*q != p)//是否为整数
            flag = 0;
        x1 = (a+q)/2;
        x2 = (a-q)/2;
        if(flag == 0)
            printf("No Solution\n");
        else
        {
            l = min(x1,x2);
            printf("%d %d\n",l,a-l);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值