SWUST OJ 之 0676 Piggy-Bank

Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid. But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!

输入

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case,there is an integer number N (1 <= N <= 500)that gives the number of various coins used in the given currency.Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams. 

输出

Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.". 

样例输入

3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4

样例输出

The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible.

分析

先来波题目解释:找出这个最坏的情况,并确定在piggy银行里的最小现金数额;
其中,两个整数 E 和 F,它们表示空猪和装满硬币的猪的重量,1 <= E <= F <= 10000;
在每个测试用例第二行,有一个整数 N (1 <= N <= 500),它给出给定货币中使用的各种硬币的数量;
下面是N行,每个指定一个硬币类型,包含两个整数 P 是硬币的货币单位,W 是重量单位克;

 

我们来思考简单情况-->只有一种硬币:
因为我们每放进去一个硬币,小猪的价值 + P、重量 + W;
所以 第二次 为 第一次 的价值 + P、重量 + W,同理每次都为前一次的基础上增加;
假设 P = 10,W = 3:

   初始:
第一次:

第二次:

第三次:

现在我们在上面的基础上扩展一下-->两种硬币:
假设第二中硬币 P = 5,W = 2:
第一次:
第二次:(min(10,INF+5))
第三次:(价值更新)
第四次:
第五次:(价值更新)
…………………………………………………………………………………………………………………………………
最终的:

 

如此,这样下去,将每种硬币依次放入更新表格即可;
注意到没,每次更新都是从硬币本身的重量 W 开始,每次重量增加 1,即dp[i] = min(dp[i], dp[i - W] + P);
这样我们就构建了一个解题思路;

代码

// Test.cpp: 定义控制台应用程序的入口点。
//

#include<iostream>
#include<stdio.h>
#include<algorithm>
#define INF 0x3f3f3f3f
int dp[10005];
using namespace std;

int main()
{
	int t;
	cin >> t;
	while (t--)
	{
		int empty, full;		
		cin >> empty >> full;		
		int weight = full - empty;		//真实可以使用的重量
		for (int i = 1; i <= weight; i++)
			dp[i] = INF;

		dp[0] = 0;						//元素值为最小价值
		int n;
		cin >> n;
		while (n--)
		{
			int P, W;
			cin >> P >> W;
			for (int i = W; i <= weight; i++)
			{
				dp[i] = min(dp[i], dp[i - W] + P);	//每次取最小值---最优迭代解
			}
		}
		if (dp[weight] == INF)			//没有解
			cout << "This is impossible." << endl;
		else
			cout << "The minimum amount of money in the piggy-bank is "
			<< dp[weight] << "." << endl;
	}

	return 0;
}

 

 

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值