zoj 2836 Number Puzzle(容斥,求1到m有多少个数能被数组里任意一个整除)

Given a list of integers (A1, A2, ..., An), and a positive integer M, please find the number of positive integers that are not greater than M and dividable by any integer from the given list.

Input

The input contains several test cases.

For each test case, there are two lines. The first line contains N (1 <= N <= 10) and M (1 <= M <= 200000000), and the second line contains A1, A2, ..., An(1 <= Ai <= 10, for i = 1, 2, ..., N).

Output

For each test case in the input, output the result in a single line.

Sample Input

3 2
2 3 7
3 6
2 3 7

Sample Output

1

4

http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=1836

#include<iostream>
#include<algorithm>
#include<string>
#include<map>
#include<vector>
#include<cmath>
#include<string.h>
#include<stdlib.h>
#include<cstdio>
#define ll long long
using namespace std;
ll n,m,s;
int x[15];
ll gcd(ll a,ll b){
        return b?gcd(b,a%b):a;}
void dfs(ll aim,ll step,ll k,ll per,ll u){//k:从第k个开始 per:当前数的最小公倍数 
	if(aim==step){
		if(u==1)
			s+=m/per; //m除所有数的最小公倍数 
		else
			s-=m/per;
		return;
	}
	else
		for(int i=k;i<n;++i) //这个K真是妙极了!(保证了每一种组合的存在) 
			dfs(aim,step+1,i+1,(per*x[i])/gcd(per,x[i]),u);
}
int main(){	
	while(cin>>n>>m){
		s=0;
		for(int i=0;i<n;++i)
			cin>>x[i];
		for(int i=1;i<=n;++i){
			if(i%2==1)
				dfs(i,0,0,1,1);//1个数的时候加,2个减,3个加,4个减... 
			else
				dfs(i,0,0,1,0);
		}
		cout<<s<<endl;
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值