poj1426 Find The Multiple(哈夫曼思想)

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

http://poj.org/problem?id=1426

找一个比N大于等于的数,使这个数每一位只有0和1,且能被N整除。

看网上有人说用了哈夫曼思想,发现在把数字存入数组的时候用到了,原来并不连续的数字可以通过一定的联系放入数组。

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;

long long mod[600001];

int main()
{
    int n;
    while(~scanf("%d",&n)&&n)
    {
        int i;
        for(i=1;;i++)
        {
            mod[i]=mod[i/2]*10+i%2;
            // x=(x/10)%n*10+i%2;
            // mod[i]表示十进制里长成二进制i这样的数
            if(mod[i]%n==0)
            {
                break;
            }
        }
        printf("%I64d\n",mod[i]);
    }
    return 0;
}


  • 2
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值