hdu 5207 求数组中任取两数的gcd最大值(灵活题)

Pick two numbers  ai,aj(ij)  from a sequence to maximize the value of their greatest common divisor.
 

Input
Multiple test cases. In the first line there is an integer  T , indicating the number of test cases. For each test cases, the first line contains an integer  n , the size of the sequence. Next line contains  n  numbers, from  a1  to  an 1T100,2n105,1ai105 . The case for  n104  is no more than  10 .
 

Output
For each test case, output one line. The output format is Case # x ans x  is the case number, starting from  1 ans  is the maximum value of greatest common divisor.
 

Sample Input
  
  
2 4 1 2 3 4 3 3 6 9
 

Sample Output
  
  
Case #1: 2 Case #2: 3
http://acm.hdu.edu.cn/showproblem.php?pid=5207

做法很巧妙。记录每个数的所有因子,排序,再找整个数组里出现次数>=2的最大因子

#include<iostream>  
#include<algorithm>  
#include<string>  
#include<map>  
#include<vector>  
#include<cmath>  
#include<string.h>  
#include<stdlib.h>  
#include<cstdio>  
#define ll long long  
using namespace std;
int x[100001];
int main(){
    int t;
    cin>>t;
    int cnt=0;
    while(t--){
        memset(x,0,sizeof(x));
        int n,a;
        cin>>n;
        int max=-1;
        for(int i=0;i<n;++i){
            cin>>a;
            if(a>max)
                max=a;
            int g=sqrt((double)a);
            for(int i=1;i<=g;++i){
                if(a%i==0){
                    x[i]++;
                    x[a/i]++;
                }
            }
            if(g*g==a)
                x[g]--;
        }
        printf("Case #%d: ", ++cnt);
        for(int i = max; i >= 1; i--){
            if(x[i]>=2){
                printf("%d\n",i);
                break;
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值