hdu 2196 Computer(经典树形DP)

Computer

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3328    Accepted Submission(s): 1680


Problem Description
A school bought the first computer some time ago(so this computer's id is 1). During the recent years the school bought N-1 new computers. Each new computer was connected to one of settled earlier. Managers of school are anxious about slow functioning of the net and want to know the maximum distance Si for which i-th computer needs to send signal (i.e. length of cable to the most distant computer). You need to provide this information. 


Hint: the example input is corresponding to this graph. And from the graph, you can see that the computer 4 is farthest one from 1, so S1 = 3. Computer 4 and 5 are the farthest ones from 2, so S2 = 2. Computer 5 is the farthest one from 3, so S3 = 3. we also get S4 = 4, S5 = 4.
 

Input
Input file contains multiple test cases.In each case there is natural number N (N<=10000) in the first line, followed by (N-1) lines with descriptions of computers. i-th line contains two natural numbers - number of computer, to which i-th computer is connected and length of cable used for connection. Total length of cable does not exceed 10^9. Numbers in lines of input are separated by a space.
 

Output
For each case output N lines. i-th line must contain number Si for i-th computer (1<=i<=N).
 

Sample Input
  
  
5 1 1 2 1 3 1 1 1
 

Sample Output
  
  
3 2 3 4 4
 


经典树形DP,就是给有权值一棵树,求其每个点到其权值最大的点。


两次dfs,第一次从根节点到叶子的最大距离和次大距离,判断一个点的从父节点过来的最大值,那么如果他的父节点存的最大值正好是从该点过来的,那么就失去了从父节点过来的状态,这时取次大距离,父次大距离不经过这个点。第二次判断他的父节点存的最大值正好是从该点过来的。

代码:

//31ms
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
using namespace std;
const int maxn=10000+200;
int head[maxn];
int dp[maxn][3];
struct node
{
    int v;
    int w;
    int next;
}edge[maxn<<1];
int t;
void add(int v,int u,int w)
{
    edge[t].v=v;
    edge[t].w=w;
    edge[t].next=head[u];
    head[u]=t++;
}
void dfs1(int k)
{
    int maxi=0,maxs=0;
    for(int i=head[k];i!=-1;i=edge[i].next)
    {
        int v=edge[i].v;
        dfs1(v);
        int temp=dp[v][0]+edge[i].w;
        if(temp>=maxi)
        {
           maxs=maxi;
           maxi=temp;
        }
        else if(temp>maxs)
        {
            maxs=temp;
        }
    }
    dp[k][0]=maxi;
    dp[k][1]=maxs;
    return;
}
void dfs2(int k)
{
    for(int i=head[k];i!=-1;i=edge[i].next)
    {
        int v=edge[i].v;
        dp[v][2]=max(dp[k][2],dp[v][0]+edge[i].w==dp[k][0]?dp[k][1]:dp[k][0])+edge[i].w;//dp[k][1]为不通过v的最大长度的子树
        dfs2(v);
    }
    return;
}
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        memset(head,-1,sizeof(head));
        t=0;
        int u,w;
        for(int i=2;i<=n;i++)
        {
            scanf("%d%d",&u,&w);
            add(i,u,w);
        }
        dfs1(1);
        dp[1][2]=0;
        dfs2(1);
        for(int i=1;i<=n;i++)
        {
            printf("%d\n",max(dp[i][0],dp[i][2]));
        }
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值