hdu 2196 Computer(DP-树形DP)

这篇博客详细探讨了HDU 2196题目中的计算机问题,通过使用树形动态规划(DP)策略进行求解,深入解析了算法思路与实现步骤。
摘要由CSDN通过智能技术生成

Computer

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3152    Accepted Submission(s): 1598


Problem Description
A school bought the first computer some time ago(so this computer's id is 1). During the recent years the school bought N-1 new computers. Each new computer was connected to one of settled earlier. Managers of school are anxious about slow functioning of the net and want to know the maximum distance Si for which i-th computer needs to send signal (i.e. length of cable to the most distant computer). You need to provide this information. 


Hint: the example input is corresponding to this graph. And from the graph, you can see that the computer 4 is farthest one from 1, so S1 = 3. Computer 4 and 5 are the farthest ones from 2, so S2 = 2. Computer 5 is the farthest one from 3, so S3 = 3. we also get S4 = 4, S5 = 4.
 

Input
Input file contains multiple test cases.In each case there is natural number N (N<=10000) in the first line, followed by (N-1) lines with descriptions of computers. i-th line contains two natural numbers - number of computer, to which i-th computer is connected and length of cable used for connection. Total length of cable does not exceed 10^9. Numbers in lines of input are separated by a space.
 

Output
For each case output N lines. i-th line must contain number Si for i-th computer (1<=i<=N).
 

Sample Input
  
  
5 1 1 2 1 3 1 1 1
 

Sample Output
  
  
3 2 3 4 4
 
每个节点记录,当前节点到它子树的最远距离和次远距离,以及这两个距离分别来自哪个儿子,这是第一遍DP做的。
第二遍DP求出每个点到所有点的最远距离。

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

#define ll long long
const int maxn = 10010;
struct Node{
    ll Maxlen[2] , son[2];
}dp[maxn];
struct edge{
    int u , v , cost , next;
    edge(int a =0 , int b = 0 , int c = 0 , int d = 0){
        u = a , v = b , cost = c , next = d;
    }
}e[4*maxn];
int N , cnt , head[maxn] , vis[maxn];

void add(int u , int v , int c){
    e[cnt] = edge(u , v , c , head[u]);
    head[u] = cnt++;
    e[cnt] = edge(v , u , c , head[v]);
    head[v] = cnt++;
}

void initial(){
    for(int i = 0; i < maxn; i++){
        head[i] = -1;
        dp[i].Maxlen[0] = 0;
        dp[i].Maxlen[1] = 0;
        dp[i].son[0] = -1;
        dp[i].son[1] = -1;
        vis[i] = 0;
    }
    cnt = 0;
}

void readcase(){
    for(int u = 2 ; u <= N ; u++){
        int v , c;
        scanf("%d%d" , &v , &c);
        add(u , v , c);
    }
}

void DP1(int u){
    vis[u] = 1;
    for(int i = head[u]; i != -1; i = e[i].next){
        int v = e[i].v;
        int c = e[i].cost;
        if(!vis[v]){
            DP1(v);
            if(dp[v].Maxlen[0]+c>dp[u].Maxlen[0]){
                dp[u].Maxlen[1] = dp[u].Maxlen[0];
                dp[u].son[1] = dp[u].son[0];
                dp[u].Maxlen[0] = dp[v].Maxlen[0]+c;
                dp[u].son[0] = v;
            }else if(dp[v].Maxlen[0]+c>dp[u].Maxlen[1]){
                dp[u].Maxlen[1] = dp[v].Maxlen[0]+c;
                dp[u].son[1] = v;
            }
        }
    }
}

void DP2(int u , int f , int cost){
    vis[u] = 1;
    if(dp[f].son[0] != u && dp[f].Maxlen[0]+cost >= dp[u].Maxlen[0]){
        dp[u].Maxlen[0] = dp[f].Maxlen[0]+cost;
        dp[u].son[0] = f;
    }else if(dp[f].son[1] != u && dp[f].Maxlen[1]+cost >= dp[u].Maxlen[0]){
        dp[u].Maxlen[0] = dp[f].Maxlen[1]+cost;
        dp[u].son[0] = f;
    }else if(dp[f].son[0] != u && dp[f].Maxlen[0]+cost >= dp[u].Maxlen[1]){
        dp[u].Maxlen[1] = dp[f].Maxlen[0]+cost;
        dp[u].son[1] = f;
    }else if(dp[f].son[1] != u && dp[f].Maxlen[1]+cost >= dp[u].Maxlen[1]){
        dp[u].Maxlen[1] = dp[f].Maxlen[1]+cost;
        dp[u].son[1] = f;
    }
    //cout << "u=" << u << " f=" << f << " cost=" << cost << " Max=" << dp[u].Maxlen[1] << " son=" << dp[u].son[1] << endl;
    for(int i = head[u]; i != -1; i = e[i].next){
        int v = e[i].v;
        int c = e[i].cost;
        if(!vis[v]) DP2(v , u , c);
    }
}

void computing(){
    DP1(1);
    memset(vis , 0 , sizeof vis);
    vis[0] = 1;
    DP2(1 , 0 , 0);
    for(int i = 1; i <= N; i++){
        cout << dp[i].Maxlen[0] << endl;
    }
}

int main(){
    while(~scanf("%d" , &N)){
        initial();
        readcase();
        computing();
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值