hdu 4990 Reading comprehension(BestCoder Round #8 1002)

Reading comprehension

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 128    Accepted Submission(s): 57


Problem Description
Read the program below carefully then answer the question.
#pragma comment(linker, "/STACK:1024000000,1024000000")
#include <cstdio>
#include<iostream>
#include <cstring>
#include <cmath>
#include <algorithm>
#include<vector>

const int MAX=100000*2;
const int INF=1e9;

int main()
{
  int n,m,ans,i;
  while(scanf("%d%d",&n,&m)!=EOF)
  {
    ans=0;
    for(i=1;i<=n;i++)
    {
      if(i&1)ans=(ans*2+1)%m;
      else ans=ans*2%m;
    }
    printf("%d\n",ans);
  }
  return 0;
}
 

Input
Multi test cases,each line will contain two integers n and m. Process to end of file.
[Technical Specification]
1<=n, m <= 1000000000
 

Output
For each case,output an integer,represents the output of above program.
 

Sample Input
  
  
1 10 3 100
 

Sample Output
  
  
1 5
 

公式,n为奇数时,n=(n+1)/2,ans=(4^n-1)/3%m,n为偶数时,n=n/2,ans=(4^n-2)/3%m,主要除法取模不好整,其实可以先对3m取模,再除3,再对m取模。

代码:
//0ms
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

long long m,n;
long long quickpow(long long x,long long n){
    long long ans=1;
    while (n) {
        if(n&1){
            ans*=x;
            ans%=3*m;
        }
        x=x*x;
        x%=3*m;
        n=n/2;
    }
    return ans;
}
int main(){
    while (~scanf("%I64d%I64d",&n,&m))
    {
        if(n&1)
        {
            n=(n+1)/2;
            long long ans=(quickpow(4, n)+3*m-1);
            ans%=3*m;
            ans/=3;
            ans=ans%m;
            printf("%I64d\n",ans);
        }
        else
        {
            n=n/2;
            long long ans=(2*quickpow(4, n)+3*m-2);
            ans%=3*m;
            ans/=3;
            ans=ans%m;
            printf("%I64d\n",ans);
        }
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值