POJ 2479 Maximum sum

Maximum sum
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 34502 Accepted: 10692

Description

Given a set of n integers: A={a1, a2,..., an}, we define a function d(A) as below:

Your task is to calculate d(A).

Input

The input consists of T(<=30) test cases. The number of test cases (T) is given in the first line of the input. 
Each test case contains two lines. The first line is an integer n(2<=n<=50000). The second line contains n integers: a1, a2, ..., an. (|ai| <= 10000).There is an empty line after each case.

Output

Print exactly one line for each test case. The line should contain the integer d(A).

Sample Input

1

10
1 -1 2 2 3 -3 4 -4 5 -5

Sample Output

13

Hint

In the sample, we choose {2,2,3,-3,4} and {5}, then we can get the answer. 

Huge input,scanf is recommended.


  杭电1003的加强版!


  用两个数组记录,一个从开始位置到当前位置最大的连续和,另一个是从结尾到当前位置最大的连续和,最后再遍历一遍前面最大和+后面最大和


代码:

#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn=50000+100;
int a[maxn];
long long sum1[maxn];
long long sum2[maxn];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        for(int i=0; i<n; i++)
        {
            scanf("%d",&a[i]);
        }
        long long ans=a[0]+a[n-1];
        long long ans1=a[0],temp1=0,temp2=0,ans2=a[n-1];
        for(int i=0; i<n; i++)//起点到当前位置最大的连续和
        {
            temp1=temp1+a[i];
            if(temp1>ans1)
            {
                ans1=temp1;
            }
            if(temp1<0)
            temp1=0;
            sum1[i]=ans1;
        }
        for(int i=n-1; i>=0; i--)//结尾到当前位置最大的连续和
        {
            temp2=temp2+a[i];
            if(temp2>ans2)
                ans2=temp2;
            if(temp2<0)
                temp2=0;
            sum2[i]=ans2;
        }
        for(int i=0; i<n-1; i++)
            ans=max(ans,sum1[i]+sum2[i+1]);
        printf("%lld\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值