POJ 2479 Maximum sum(dp—求最大的两个不相交的字段和)

Maximum sum
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 38128 Accepted: 11915

Description

Given a set of n integers: A={a1, a2,..., an}, we define a function d(A) as below:
Your task is to calculate d(A).

Input

The input consists of T(<=30) test cases. The number of test cases (T) is given in the first line of the input. 
Each test case contains two lines. The first line is an integer n(2<=n<=50000). The second line contains n integers: a1, a2, ..., an. (|ai| <= 10000).There is an empty line after each case.

Output

Print exactly one line for each test case. The line should contain the integer d(A).

Sample Input

1

10
1 -1 2 2 3 -3 4 -4 5 -5

Sample Output

13

Hint

In the sample, we choose {2,2,3,-3,4} and {5}, then we can get the answer. 

Huge input,scanf is recommended.

题意:给出一个含有n个数的数列,求出数列中最大的两个不相交的字段和。

题解:对于每一个i而言,都有[0, i ) 和[i, n ) 这两段 。我们分别求出每个 i 对应这两段的最大字段和,然后遍历所有的i,得到最大值即可。

代码如下: 

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define maxn 50010 
int a[maxn],left[maxn],right[maxn];
int main()
{
	int t,n,i;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		for(i=0;i<n;++i)
			scanf("%d",&a[i]);
		left[0]=a[0];
		for(i=1;i<n;++i)//此时left[i]为包含i的最大字段和 
		{
			if(left[i-1]<0)
				left[i]=a[i];
			else
				left[i]=left[i-1]+a[i];
		}
		for(i=1;i<n;++i)//此时left[i]为i左边(包含i这个点)的最大字段和 
			left[i]=max(left[i],left[i-1]);
		right[n-1]=a[n-1];
		for(i=n-2;i>=0;--i)
		{
			if(right[i+1]<0)
				right[i]=a[i];
			else
				right[i]=right[i+1]+a[i];
		}
		for(i=n-2;i>=0;--i)
			right[i]=max(right[i],right[i+1]);
		int ans=-10000*maxn;
		for(i=1;i<n;++i)
			ans=max(ans,left[i-1]+right[i]);
		printf("%d\n",ans);
	}
	return 0;
} 


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值