POJ 1948 Triangular Pastures(二维背包)

Triangular Pastures
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 6774 Accepted: 2199

Description

Like everyone, cows enjoy variety. Their current fancy is new shapes for pastures. The old rectangular shapes are out of favor; new geometries are the favorite. 

I. M. Hei, the lead cow pasture architect, is in charge of creating a triangular pasture surrounded by nice white fence rails. She is supplied with N (3 <= N <= 40) fence segments (each of integer length Li (1 <= Li <= 40) and must arrange them into a triangular pasture with the largest grazing area. Ms. Hei must use all the rails to create three sides of non-zero length. 

Help Ms. Hei convince the rest of the herd that plenty of grazing land will be available.Calculate the largest area that may be enclosed with a supplied set of fence segments. 

Input

* Line 1: A single integer N 

* Lines 2..N+1: N lines, each with a single integer representing one fence segment's length. The lengths are not necessarily unique. 

Output

A single line with the integer that is the truncated integer representation of the largest possible enclosed area multiplied by 100. Output -1 if no triangle of positive area may be constructed. 

Sample Input

5
1
1
3
3
4

Sample Output

692

Hint

[which is 100x the area of an equilateral triangle with side length 4] 


   题意:

  求n条线段构成的三角形的最大面积*100

  题解

  由于三角形有三个边,并且所有的线段都要用到,于是可以用dp[i][j]表示边长为i,j,sum-i-j的三角形,由于是二维的,j,k边有一个可以取到0,另一个减去a后要大于等于0,最后用海伦公式算面积。


  代码:

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
using namespace std;
int dp[1005][1005];
int n,sum;
int main()
{
    while(~scanf("%d",&n))
    {
        sum=0;
        int a;
        memset(dp,0,sizeof(dp));
        dp[0][0]=1;
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a);
            sum+=a;
            for(int j=1000;j>=0;j--)
            {
                for(int k=1000;k>=0;k--)
                {
                    if((k-a>=0&&dp[j][k-a])||(j-a>=0&&dp[j-a][k]))
                    {
                        dp[j][k]=1;
                    }
                }
            }
        }
        int ans=0;
        for(int i=1;i<=sum/2;i++)
        {
            for(int j=1;j<=sum/2;j++)
            {
               if(dp[i][j]&&(i+j>sum-i-j))
               {
                   double p=sum*1.0/2;
                   int temp=(int)(sqrt(p*(p-i)*(p-j)*(p-sum+i+j))*100);
                   ans=max(ans,temp);
               }
            }
        }
        if(ans)
        printf("%d\n",ans);
        else
        printf("-1\n");
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值