Poj-1979


     :点击打开题目链接

Red and Black
Time Limit: 1000MS
Memory Limit: 30000K
Total Submissions: 30701
Accepted: 16712

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

Source


题意:就是让你从@出发最多能走多少个 “.”,#代表不能过去,最后别忘了加@本身,DFS




<span style="font-size:24px;">#include<cstdio>
#include<string.h>
char map[22][22];
int ans; 

int px[4]={-1,1,0,0};//坐标位移的转换 
int py[4]={0,0,-1,1};

void f(int x0,int y0)
{
	int i;
	for(i=0;i<4;++i)
	{
		int nx=x0+px[i];
		int ny=y0+py[i];
		if(map[nx][ny]!='#')
		{
			map[nx][ny]='#';
			ans++;//每走一步加一次 
			f(nx,ny);
		}
	}
}


int main()
{
	int x,y;// x代表行 y代表列 
	while(scanf("%d%d",&x,&y)!=EOF&&x!=0||y!=0)
	{
		getchar();
		memset(map,'#',sizeof(map));//首先在外部筑了一层墙 这样判断条件就会少很多 
		int i,j,x0,y0;
		for(j=1;j<=y;++j)
		{
			for(i=1;i<=x;++i)
			{
				scanf("%c",&map[i][j]); 
				if(map[i][j]=='@')
				{
					x0=i;y0=j;// 开始的坐标 
					map[i][j]='#'; //这个是基点 首先进行变换 
				}
			}	
			getchar();
		}
		ans=0;
		f(x0,y0);
		printf("%d\n",ans+1);
	}
} </span>







评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值