1103. Integer Factorization

1103. Integer Factorization (30)

时间限制
1200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The K-P factorization of a positive integer N is to write N as the sum of the P-th power of K positive integers. You are supposed to write a program to find the K-P factorization of N for any positive integers N, K and P.

Input Specification:

Each input file contains one test case which gives in a line the three positive integers N (<=400), K (<=N) and P (1<P<=7). The numbers in a line are separated by a space.

Output Specification:

For each case, if the solution exists, output in the format:

N = n1^P + ... nK^P

where ni (i=1, ... K) is the i-th factor. All the factors must be printed in non-increasing order.

Note: the solution may not be unique. For example, the 5-2 factorization of 169 has 9 solutions, such as 122 + 42 + 22 + 22 + 12, or 112 + 62 + 22 + 22 + 22, or more. You must output the one with the maximum sum of the factors. If there is a tie, the largest factor sequence must be chosen -- sequence { a1, a2, ... aK } is said to be larger than { b1, b2, ... bK } if there exists 1<=L<=K such that ai=bi for i<L and aL>bL

If there is no solution, simple output "Impossible".

Sample Input 1:
169 5 2
Sample Output 1:
169 = 6^2 + 6^2 + 6^2 + 6^2 + 5^2
Sample Input 2:
169 167 3
Sample Output 2:
Impossible
 
 
#include<stdio.h>
#include<vector>
#include<numeric>
#include<algorithm>
using namespace std;

//表示上线,如p=4的时候,ceil[4] = 4,表示4^4<400而5^4》400
//这个4就是ans中每个数字的上限,ans[i]必须都小于等于acei[p],
//因为ceil已经是关键字,所以用了aceil 
int aceil[8] = {0, 0, 20, 7, 4, 3, 2, 2};

int n, k, p;//放在全局变量中,这样DFS可以少一些参数传递
vector<int> v;//存放可能的答案 
vector<vector<int> > ans;//存放所有的答案 

int kpow(int x, int y)
{
	int res = x;
	while(-- y)
		res *= x;
	return res;
}

void DFS(int start, int curSum, int count)
{
	for(int i = start; i <= aceil[p]; i ++)
	{
		int tmpSum = curSum + kpow(i, p);//这里若自己调用pow会出现case 5过不去
		if(tmpSum > n)//剪枝,和大了 
			return ; 
		if(count == k-1 && tmpSum < n)//剪枝,到达个数了,但是和小了 
			continue;
		if(count == k-1 && tmpSum == n)
		{
			v.push_back(i);
			ans.push_back(v);
			v.pop_back();
			return ;
		}
		
		v.push_back(i);//典型DFS模式:挖坑,跳入,再填坑
		DFS(i, tmpSum, count+1) ;
		v.pop_back();
	}
	return ;
}

bool cmp(vector<int> v1, vector<int> v2)
{
	if(accumulate(v1.begin(), v1.end(), 0) != accumulate(v2.begin(), v2.end(), 0))
		return accumulate(v1.begin(), v1.end(), 0) > accumulate(v2.begin(), v2.end(), 0);
	else
		return v1 > v2;//vector自带的<运算符,可以按元素依次比较,符合我们的要求 
}

void print(vector<int> vx)
{
	printf("%d = ", n);
	for(int i = 0; i < vx.size(); i ++)
		if(i)
			printf(" + %d^%d", vx[i], p);
		else
			printf("%d^%d", vx[i], p);
} 

int main()
{
	//freopen("F://Temp/input.txt", "r", stdin);
	scanf("%d%d%d", &n, &k, &p);
	
	DFS(1, 0, 0);
	if(ans.size() == 0)
	{
		printf("Impossible\n");
		return 0;
	}
	
	for(int i = 0; i < ans.size(); i ++)
		reverse(ans[i].begin(), ans[i].end());
		
	sort(ans.begin(), ans.end(), cmp);
	print(ans[0]);
	printf("\n");
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值