1046. Shortest Distance

1046. Shortest Distance (20)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D2 ... DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:
5 1 2 4 14 9
3
1 3
2 5
4 1
Sample Output:
3
10
7
这种注意运用两种思路,第一种数组加倍,解决了循环数组的难题。第二种就是改变数组中的值,变为累加和。但是第一种注意处理case 3的超时。下面分别贴出两种的代码,第一种的case 3 博主就没有处理。
include<stdio.h>

struct dis
{
	int city;
	int distance;
}buf[200004];

int main()
{
	freopen("F://Temp/input.txt", "r", stdin);
	int n;
	scanf("%d", &n);
	
	for(int i = 1; i <= n; i ++)
	{
		scanf("%d", &buf[i].distance);
		buf[i].city = i;
		buf[n+i].distance = buf[i].distance;
		buf[n+i].city = i;
	}
	
	
	int m;
	scanf("%d", &m);
	
	while(m --)
	{
		int start, end;
		scanf("%d%d", &start, &end);
		int res1 = 0, res2 = 0;
		
		for(int i = start; buf[i].city != end; i ++)
			res1 += buf[i].distance;
		
		for(int i = end; buf[i].city != start; i ++)
			res2 += buf[i].distance;
			
		if(res1 < res2)
			printf("%d\n", res1);
		else
			printf("%d\n", res2);
	}
	
	return 0;
}







#include<stdio.h>
#include<string.h>

int main()
{
	freopen("F://Temp/input.txt", "r", stdin);
	int n, m;
	int distance[100002];
	scanf("%d", &n);
	memset(distance, 0, sizeof(distance));
	
	for(int i = 2; i <= n; i ++)
		scanf("%d", &distance[i]);
	
	for(int i = 2; i <= n; i ++)
		distance[i] += distance[i-1];
	
	scanf("%d", &distance[n+1]);
	
	scanf("%d", &m);
	for(int i = 0; i < m; i ++)
	{
		int s, t, min = 0x7fffffff;
		scanf("%d%d", &s, &t);
		if(s > t)
		{
			int tmp = s;
			s = t;
			t = tmp;
		}
		if(distance[t]-distance[s] < distance[s]+distance[n+1]+distance[n]-distance[t])
			min = distance[t] - distance[s];
		else
			min = distance[s] + distance[n+1] + distance[n] - distance[t];
		
		printf("%d\n", min);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值