[PAT A1046]Shortest Distance

[PAT A1046]Shortest Distance

题目描述

1046 Shortest Distance (20 分)The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

输入格式

Each input file contains one test case. For each case, the first line contains an integer N (in [3,10​5​​]), followed by N integer distances D​1​​ D​2​​⋯ D​N​​, where D​i​​ is the distance between the i-th and the (i+1)-st exits, and D​N​​ is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤10​4​​), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10​7​​.

输出格式

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

输入样例

5 1 2 4 14 9
3
1 3
2 5
4 1

输出样例

3
10
7

分析

  1. 题目翻译:最短距离,这个任务十分的简单,给你N个结点围成一个圈,你应该给出任意两个点之间的最短距离。
  2. 输入格式:首先是输入N[3,105],表示有N个点,然后输入D1,D2……DN,例如Di就表示第i个点到第i+1个点的距离,DN存放的是第N个点到第一个点的距离;
  3. 然后输入M[≤104],表示接下来有M组数据,对于每组数据要求它们之间的最短距离
  4. 算法分析:首先我是这样想的,把D1到DN都存放到数组里面,因为最短距离要么就是顺时针,要么就是逆时针(因为它们之间是不能跨过点的,比如求点1到点4的距离,要么就是点1到点2+点2到点3+点3到点4的距离,要么就是点4到点5+点5到点6+……+点N-1到点N+点N到点1的距离),我们就从小的点出发,累加到大的点,最后比较顺时针和逆时针的长度,得出结果。
这个结果拿了17分(满分20),最后一组数据是超时了,说明我们还有缺陷,这个时候要是时间不够的话我推荐先往后做,不要因为为了这3分导致后面的题目没有完成
#include<iostream>
using namespace std;
const int maxn = 100010;  //数组最大长度
int dis[maxn] = { 0 }; //初始化
int main()
{
 int N, M, all_dis = 0;  //all_dis用于计算围成一圈的总长度
 cin >> N;
 for (int i = 1; i <= N; i++)
 {
  cin >> dis[i];
  all_dis += dis[i];
 }
 cin >> M;
 while (M--)
 {
  int a, b, dist = 0;   //dist用于存储点a到点b的长度
  cin >> a >> b;
  if (a < b) {
   while (a < b) dist += dis[a++];   //a<b就不断从a加到b为止
  }
  else{
   while (b < a) dist += dis[b++];   //同理,b<a就不断从b加到a为止
  }
  cout << ((dist < (all_dis - dist)) ? dist : (all_dis - dist)) << endl;//有可能顺时针短,有可能逆时针短,所以需要比较当前计算长度和总长度减去当前计算长度的大小
 }
 return 0;
}
好,接下来我们来说为什么会超时,因为我们最多最多有105个点,查询次数最多有104次,所以在极端情况下我们要做的操作有109次,所以我马上想到了使用数列和的概念,利用数列和的差得到中间一段数的和
#include<iostream>
using namespace std;
const int maxn = 100010;
int dis[maxn] = { 0 };
int main()
{
 int N, M, all_dis = 0;
 cin >> N;
 for (int i = 1; i <= N; i++)
 {
  cin >> dis[i];
  all_dis += dis[i];
  dis[i] = all_dis;
 }
 cin >> M;
 while (M--)
 {
  int a, b, dist = 0;
  cin >> a >> b;
  if (a < b) dist = dis[b - 1] - dis[a - 1];
  else dist = dis[a - 1] - dis[b - 1];
  cout << ((dist < (all_dis - dist)) ? dist : (all_dis - dist)) << endl;
 }
 return 0;
}
水平有限,如果代码有任何问题或者有不明白的地方,欢迎在留言区评论;也欢迎各位大牛提出宝贵的意见!
  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L). To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river. Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to M rocks (0 ≤ M ≤ N). FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks. Input Line 1: Three space-separated integers: L, N, and M Lines 2..N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position. Output Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks Sample Inputcopy Outputcopy 25 5 2 2 14 11 21 17 4 Hint Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).
07-24

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值