(hdu 简单题 128道)hdu 2001 计算两点间的距离

题目:

计算两点间的距离

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 115566    Accepted Submission(s): 44177


Problem Description
输入两点坐标(X1,Y1),(X2,Y2),计算并输出两点间的距离。
 

Input
输入数据有多组,每组占一行,由4个实数组成,分别表示x1,y1,x2,y2,数据之间用空格隔开。
 

Output
对于每组输入数据,输出一行,结果保留两位小数。
 

Sample Input
  
  
0 0 0 1 0 1 1 0
 

Sample Output
  
  
1.00 1.41
 

Author
lcy
 

Source
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   2002  2000  2010  2009  2012 



题目分析:

                 简单题。



代码如下:

/*
 * g.cpp
 *
 *  Created on: 2015年3月20日
 *      Author: Administrator
 
 hdu 2001
 */


#include <iostream>
#include <cstdio>
#include <cmath>

struct PPoint{//结构体尽量不要定义成Point这种,容易和C/C++本身中的变量同名
	double x;
	double y;

	PPoint(double _x = 0,double _y = 0):x(_x),y(_y){

	}

	PPoint operator - (const PPoint& op2) const{
		return PPoint(x - op2.x,y - op2.y);
	}

	double operator^(const PPoint &op2)const{
		return x*op2.y - y*op2.x;
	}
};


inline double sqr(const double &x){
	return  x*x;
}

inline double dis2(const PPoint &p0,const PPoint &p1){
	return sqr(p0.x - p1.x) + sqr(p0.y - p1.y);
}

inline double dis(const PPoint& p0,const PPoint& p1){
	return sqrt(dis2(p0,p1));
}


int main(){
	PPoint p1,p2;
	while(scanf("%lf %lf %lf %lf",&p1.x,&p1.y,&p2.x,&p2.y)!=EOF){
		printf("%.2lf\n",dis(p1,p2));
	}

	return 0;
}




  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

帅气的东哥

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值