PAT -- 甲级1004(1004 Counting Leaves)

16 篇文章 0 订阅
16 篇文章 0 订阅

1004 Counting Leaves (30 分)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<1000<N<1000<N<100, the number of nodes in a tree, and MMM (<N<N<N), the number of non-leaf nodes. Then MMM lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with NNN being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1

给你n个结点,当中有m个父亲节点,接下来又m行,每行的分别给父亲节点father,其k个儿子数,接下来k个数代表father的儿子节点,求该棵以1为根节点的树每层的叶子节点数。

思路:DFS遍历这颗树,注意m为0的时候相当于有n个根节点,所以特判一下输出N。

Code

#include <bits/stdc++.h>

using namespace std;
int N,M;
vector<int> Tree[105];
map<int, int > vis;

void DFS (int idx, int k) {
  if (Tree[idx].size() == 0) {
    vis[k]++;
    return ;
  }
  for (int i = 0; i < Tree[idx].size(); i++) {
    DFS(Tree[idx][i], k + 1);
  }
}

int main() {
  int father, son, k;
  cin >> N >>M;
  while (M--) { //build
    cin >> father >> k;
    while (k--) {
      cin >> son;
      Tree[father].push_back(son);
    }
  }
  if (M == 0) {
    cout << N << endl;
  } else {
    DFS(1, 1);
    cout << vis[1];
    for (int i = 2; i <= vis.size(); i++) {
      cout << " " << vis[i];
    }
    cout << endl;
  }
  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

小胡同的诗

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值