PAT --甲级1005(1005 Spell It Right )

1005 Spell It Right (20 分)

Given a non-negative integer NNN, your task is to compute the sum of all the digits of NNN, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an NNN (≤10100\le 10^{100}10100).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345

Sample Output:

one five

给一端长度最多为101的数字串,每个位置的数字相加后将其结果用英文表示(把结果的每位数字用英文替换)

思路:模拟

Code

#include <bits/stdc++.h>

using namespace std;

stack<string> stk;
string change[10] = {"zero", "one", "two", "three", "four", "five", "six", "seven", "eight", "nine"};

int main() {
  string num;
  long long sum = 0;
  cin >> num;
  for (int i = num.size() - 1; i >= 0; i--) {
    sum += num[i] - '0';
  }
  while (!stk.empty()) {
    stk.pop();
  }
  do {
    stk.push(change[sum % 10]);
    sum /= 10;
  }while(sum);
  cout << stk.top();
  stk.pop();
  while (!stk.empty()) {
    cout << " " << stk.top();
    stk.pop();
  }
  cout << endl;
  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

小胡同的诗

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值