PAT甲级-1005 Spell It Right

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:
Each input file contains one test case. Each case occupies one line which contains an N (≤10^100).

Output Specification:
For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:
12345

Sample Output:
one five

题目意思大概是我们输入一个非负数,然后计算每一位加起来的和并输出每一位对应的英文。
解题思路:首先这个数的范围是10的100次方,我们的long long类型范围也不够,所以肯定要用字符串输入或者字符输入,我们把字符串的每一位上的数字逐一加到一个int变量上,然后这个变量可以转换成字符串,并依据字符串对应的每一位的数从哈希表中取字符串并输出。

#include<iostream>
#include<string>
using namespace std;

string s[10]={"zero","one","two","three","four","five","six","seven","eight","nine"};

int main()
{
	string N;int sum=0;
	cin>>N;
	for(int i=0;i<N.size();i++)
	{
		sum+=N[i]-'0';
	}
	/* 字符输入的方法
	char a;
	while(isdigit(a=getchar()))//当输入是数字时
    {
        sum+=a-'0';
    }
    */
	string ssum=to_string(sum);
	for(int i=0;i<ssum.size();i++)
	{
		if(i>0) cout<<" ";
		cout<<s[ssum[i]-'0'];
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值