畅通工程(杭电1232)

Problem Description

某省调查城镇交通状况,得到现有城镇道路统计表,表中列出了每条道路直接连通的城镇。省政府“畅通工程”的目标是使全省任何两个城镇间都可以实现交通(但不一定有直接的道路相连,只要互相间接通过道路可达即可)。问最少还需要建设多少条道路?

 

 

Input

测试输入包含若干测试用例。每个测试用例的第1行给出两个正整数,分别是城镇数目N ( < 1000 )和道路数目M;随后的M行对应M条道路,每行给出一对正整数,分别是该条道路直接连通的两个城镇的编号。为简单起见,城镇从1到N编号。
注意:两个城市之间可以有多条道路相通,也就是说
3 3
1 2
1 2
2 1
这种输入也是合法的
当N为0时,输入结束,该用例不被处理。

 

 

Output

对每个测试用例,在1行里输出最少还需要建设的道路数目。

 

 

Sample Input

 

4 2 1 3 4 3 3 3 1 2 1 3 2 3 5 2 1 2 3 5 999 0 0

 

 

Sample Output

 
1 0 2 998

Hint

Hint Huge input, scanf is recommended.

 

看到这种题,第一反应是用并查集写,最后统计有多少个集合就可以

package Test;

import java.util.Scanner;

public class Main {
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		int N = sc.nextInt();
		int result;
		while (N != 0) {
			result = N - 1;
			int M = sc.nextInt();
			int[] father = new int[N];
			for (int i = 1; i <= N; i++) {
				father[i - 1] = i;
			}
			for (int i = 0; i < M; i++) {
				int x = sc.nextInt();
				int y = sc.nextInt();
				int xF = find(father, x);
				int yF = find(father, y);
				if (xF != yF) {
					father[yF - 1] = xF;
					result--;
				}
			}
			System.out.println(result);
			N = sc.nextInt();
		}
		sc.close();
	}

	private static int find(int[] father, int n) {
		int res = n;
		while (father[res - 1] != res) {
			res = father[res - 1];
		}
		int temp;
		while (res != n) {
			temp = father[n - 1];
			father[n - 1] = res;
			n = temp;
		}
		return res;
	}
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值