【PAT(甲级)】1064 Complete Binary Search Tree

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4

解题思路:

题目给出一个完全二叉树的节点信息,让你根据这颗完全二叉树建立唯一存在的一棵二叉搜索树,并层序输出其节点。

由题意,这棵二叉搜索树必定存在,且节点就是给出的完全二叉树的节点,那么二叉搜索树的中序输出是从小到大规则排序的,那我们是不是把完全二叉树的节点由小到大排序,就可以得到二叉搜索树的中序输出了?

既然已经可以得到二叉搜索树的中序输出,那么我们可以用数组来模拟树,中序输出的顺序是左——根——右;假设根节点下标为i,左子树就是2*i,右子树就是2*i+1;由此递归出的数组,从前往后刚好就是二叉搜索树的层序输出。

注意,根节点的下标要从1开始。(不然你递归的时候2*i不就死循环了嘛)

代码:

#include<bits/stdc++.h>
using namespace std;
int N;
int t[1001],number[1001];
int tip = 0;
void inorder(int a){
	if(a>N) return;
	inorder(a*2);
	t[a] = number[tip++];
	inorder(a*2+1);
}

int main(){
	cin>>N;
	for(int i=0;i<N;i++){
		cin>>number[i];
	}
	sort(number,number+N);
	inorder(1);
	for(int i=1;i<=N;i++){
		cout<<t[i];
		if(i!=N) cout<<" ";
	}
	return 0;
}

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值