hdu1051 woodensticks 简单

Wooden Sticks

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 10   Accepted Submission(s) : 7
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 

(a) The setup time for the first wooden stick is 1 minute. 
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup. 

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.

Output

The output should contain the minimum setup time in minutes, one per line.

Sample Input

3 
5 
4 9 5 2 2 1 3 5 1 4 
3 
2 2 1 1 2 2 
3 
1 3 2 2 3 1

Sample Output

2
1
3

Source

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
struct wood
{
	int l,w;//l长度 w重量 
};

bool cmp(wood a,wood b)
{ 
	if(a.l<b.l)
	return true;
	else if(a.w<b.w&&a.l==b.l)
	return true;
	return false;
}//对l进行升序排列,若相等,对于w升序排列 

int main()
{
	int N;
	scanf("%d",&N);
	while(N--)
	{
		int n,i;
		scanf("%d",&n);
		wood a[n];
		for(i=0;i<n;i++)
		scanf("%d%d",&a[i].l,&a[i].w);
	
		sort(a,a+n,cmp);
		int sum=0,t=n;//t代表需要处理多少根 
		int mark[n];//标记数组,若值为0代表未处理,若为1代表处理过 
		memset(mark,0,sizeof(mark)); 
		while(t!=0)
		{
			for(i=0;i<n&&mark[i]==1;i++);//从未处理的开始处理,for循环加;代表:下面的for循环结束之后不再后退执行这个 
			for(int j=i+1;j<n;j++)
			{	
				if(mark[j]==0&&a[j].w>=a[i].w)//开始比较,并符合条件 
				{
					mark[i]=1;
					t--;//又处理掉一根 
					i=j;//交替,i继续与它后面的比较 
				}
    		}//for 
			mark[i]=1;//最后一个给标记因为要单独加一个。 
			t--;
			sum++;//一组结束 
		}//while 
		printf("%d\n",sum);	
	}
	return 0;
}

下面这种更简单易懂一些。

#include <iostream>
#include <algorithm>
using namespace std;

struct Node
{
	int head;
	int end;
	int flag;
}node[5005];

int cmp(Node a,Node b)
{
	if(a.head<b.head)
	return 1;
	else if(a.head==b.head&&a.end<b.end)
	return 1;
	return 0;
}

int main()
{
	int n,t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		int i,j,sum=0,cnt=0;
		for(i=0;i<n;i++)
		{
			scanf("%d%d",&node[i].head,&node[i].end);
			node[i].flag=0;
		}
		sort(node,node+n,cmp);
		int ans=0;
		for(i=0;i<n;i++)
		{
			if(!node[i].flag)
			{
				node[i].flag=1;
				ans++;
				int temp=node[i].end;
				for(int j=i+1;j<n;j++)
				{
					if(!node[j].flag&&node[j].end>=temp)
					{
						node[j].flag=1;
						temp=node[j].end;
					}
				}
			}
		}
		printf("%d\n",ans);
	}
	return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值