hdu3085 Nightmare Ⅱ 双向BFS 模板题

Nightmare Ⅱ

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3068    Accepted Submission(s): 874


Problem Description
Last night, little erriyue had a horrible nightmare. He dreamed that he and his girl friend were trapped in a big maze separately. More terribly, there are two ghosts in the maze. They will kill the people. Now little erriyue wants to know if he could find his girl friend before the ghosts find them.
You may suppose that little erriyue and his girl friend can move in 4 directions. In each second, little erriyue can move 3 steps and his girl friend can move 1 step. The ghosts are evil, every second they will divide into several parts to occupy the grids within 2 steps to them until they occupy the whole maze. You can suppose that at every second the ghosts divide firstly then the little erriyue and his girl friend start to move, and if little erriyue or his girl friend arrive at a grid with a ghost, they will die.
Note: the new ghosts also can devide as the original ghost.
 

Input
The input starts with an integer T, means the number of test cases.
Each test case starts with a line contains two integers n and m, means the size of the maze. (1<n, m<800)
The next n lines describe the maze. Each line contains m characters. The characters may be:
‘.’ denotes an empty place, all can walk on.
‘X’ denotes a wall, only people can’t walk on.
‘M’ denotes little erriyue
‘G’ denotes the girl friend.
‘Z’ denotes the ghosts.
It is guaranteed that will contain exactly one letter M, one letter G and two letters Z. 
 

Output
Output a single integer S in one line, denotes erriyue and his girlfriend will meet in the minimum time S if they can meet successfully, or output -1 denotes they failed to meet.
 

Sample Input
 
 
3 5 6 XXXXXX XZ..ZX XXXXXX M.G... ...... 5 6 XXXXXX XZZ..X XXXXXX M..... ..G... 10 10 .......... ..X....... ..M.X...X. X......... .X..X.X.X. .........X ..XX....X. X....G...X ...ZX.X... ...Z..X..X
 

Sample Output
 
 
1 1 -1
 

#include<stdio.h>
#include<queue>
#include<string.h>
#include<math.h>
using namespace std;
int n,m;
int mx,my,gx,gy,step;
char map[810][810];
int dir[4][2]={1,0,-1,0,0,1,0,-1};
int vis[2][810][810];
//实质上所有知道初始点和目标点的BFS题都可以使用双向搜索,节省时间 
struct node{
	int x,y;
}temp,z[2];

queue<node>q[2];

//题意的意思是鬼魂会扩散每秒2步。可以理解为核弹在那个点爆炸,每秒钟扩散2千米的冲击波,可以穿墙,直到覆盖整个地图,
//即这对男女的见面是有倒计时的 
int judge(node temp)
{
	if(temp.x<0||temp.y<0||temp.x>=n||temp.y>=m||map[temp.x][temp.y]=='X')
	return 1;
	if(abs(temp.x-z[0].x)+abs(temp.y-z[0].y)<=2*step)//曼哈顿距离 
	return 1;
	if(abs(temp.x-z[1].x)+abs(temp.y-z[1].y)<=2*step)
	return 1;

	return 0;
}


int bfs(int w)
{
	node cur,next;
	int sum=q[w].size();//关键 每次bfs只消除队列里的元素,而不是向单向BFS一次性处理到队列尾空。
	//这里主要是为了男生和女生同步 
	
	while(sum--)
	{
		cur=q[w].front();
		q[w].pop();
		if(judge(cur))//这里进行合法性判断 
		continue;
		for(int i=0;i<4;i++)
		{
			next.x=cur.x+dir[i][0];
			next.y=cur.y+dir[i][1];
			if(judge(next))//上面判断过了,这里也要再进行合法性判断  
			continue; 
			if(!vis[w][next.x][next.y])
			{
				if(vis[1-w][next.x][next.y])//1-w很巧妙,如果是另一个人已经到过这个地方,就说明他们已经可以见面了 
				return 1;
				vis[w][next.x][next.y]=1;
				q[w].push(next); 
			}
		}
	}
	return 0;
}


int solve()
{
	while(!q[0].empty())
	q[0].pop();
	while(!q[1].empty())
	q[1].pop();
	temp.x=mx;
	temp.y=my;
	q[0].push(temp);
	temp.x=gx;
	temp.y=gy;
	q[1].push(temp);//push初始点
	
	memset(vis,0,sizeof(vis));
	vis[0][mx][my]=vis[1][gx][gy]=1;
	step=0;
	
	while(!q[0].empty()||!q[1].empty())
	{
		step++;
		if(bfs(0)==1) return step;//男生每分钟走3步 
		if(bfs(0)==1) return step;
		if(bfs(0)==1) return step;
		if(bfs(1)==1) return step;//女生走一步 
	}
	return -1;
}

int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		int cnt=0;
		
		for(int i=0;i<n;i++)
		{
			scanf("%s",map[i]);
			for(int j=0;j<m;j++)
			{
				if(map[i][j]=='Z')
				{
					z[cnt].x=i,z[cnt].y=j;
					cnt++;
				}
				if(map[i][j]=='M')
				mx=i,my=j;
				if(map[i][j]=='G')
				gx=i,gy=j;
			}

		}
		
		printf("%d\n",solve());
	}
	return 0;
 } 


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值