hdu2577 How to Type

How to Type

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7803    Accepted Submission(s): 3502


Problem Description
Pirates have finished developing the typing software. He called Cathy to test his typing software. She is good at thinking. After testing for several days, she finds that if she types a string by some ways, she will type the key at least. But she has a bad habit that if the caps lock is on, she must turn off it, after she finishes typing. Now she wants to know the smallest times of typing the key to finish typing a string.
 

Input
The first line is an integer t (t<=100), which is the number of test case in the input file. For each test case, there is only one string which consists of lowercase letter and upper case letter. The length of the string is at most 100.
 

Output
For each test case, you must output the smallest times of typing the key to finish typing this string.
 

Sample Input
 
 
3PiratesHDUacmHDUACM
 

Sample Output
 
 
888
Hint
The string “Pirates”, can type this way, Shift, p, i, r, a, t, e, s, the answer is 8.The string “HDUacm”, can type this way, Caps lock, h, d, u, Caps lock, a, c, m, the answer is 8The string "HDUACM", can type this way Caps lock h, d, u, a, c, m, Caps lock, the answer is 8
 

第一种 模拟
#include<stdio.h>
#include<iostream>
#include<string.h>
using namespace std;

int main()
{
	int n;
	char s[105];
	int num[105];
	while(scanf("%d",&n)!=EOF)
	{
		for(int i=0;i<n;i++)
		{
			scanf("%s",s); 
			int len=strlen(s);
			int ans=len;//每个键肯定要按一次。 
			s[len]='{';
			int flag=0;//有没有开启大写键 
			for(int j=0;j<len;j++)
			{
				if(s[j]<'a')//大写字母 
				{
					if(s[j+1]<'a'&&!flag)//当前的和之后的如果都是大写字母,即超过连续两个大写字母则用大写键 
					{
						flag=1;
						ans++;
					}
					else if(s[j+1]>='a'&&!flag) 
					{
						ans++;//用shift 
					}
				}
				else//小写字母 
				{
					if(s[j+1]<'a'&&flag)//注意大写键开启时,用shift也可以写出小写字母 
					{
						ans++;//用shift 
					}
					else if(flag)//发现大写键开启则关闭 
					{
						ans++;
						flag=0;
					}
				}
			}
			if(flag)
			ans++;
			printf("%d\n",ans);
		}
	}
	return 0;
}

第二种 入门动态规划
#include <stdio.h>  
#include <string.h>  
#include <algorithm>  
using namespace std;  
//题意:要求一个字符串输入,按键盘的最少次数。有Caps Lock和Shift两种转换大小写输入的方式
//思路:用dpa与dpb数组分别记录Caps Lock的开关状态 
//dpa 表示此时灯是亮的,dpb表示此时灯是暗的。 
char str[111];  
int dpa[111],dpb[111];  
  
int main()  
{  
    int t,i,len,flag;  
    scanf("%d",&t);  
    while(t--)  
    {  
        scanf("%s",str+1);  
        dpa[0] = 0;  
        dpb[0] = 1;  
        for(i = 1; str[i]; i++)  
        {  
            if(str[i]>='a' && str[i]<='z')  //小写字母 
            {  
                dpa[i] = min(dpa[i-1]+1,dpb[i-1]+2);//若大写灯不亮,则直接按字母;若灯亮,则先关灯再按字母   按完之后结果是不亮 
                dpb[i] = min(dpa[i-1]+2,dpb[i-1]+2);//若大写灯不亮,则要先按字母,再开灯;若灯亮,则按shift+字母   按完之后 结果是灯亮 
            }  
            else if(str[i]>='A' && str[i]<='Z')  //大写字母 
            {  
                dpa[i] = min(dpa[i-1]+2,dpb[i-1]+2); //若大写灯不亮,则按按shift+字母;若灯亮,则先按字母,再关灯  按完之后结果是不亮 
                dpb[i] = min(dpa[i-1]+2,dpb[i-1]+1); //若大写灯不亮,则要先开灯再按字母;若灯亮,则直接字母   按完之后 结果是灯亮 
            }  
        }  
        printf("%d\n",min(dpb[i-1]+1,dpa[i-1]));//最后如果灯还亮着,要关灯,dpb+1  
    }  
  
    return 0;  
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值