HDU 2577 How to Type 动态规划

How to Type

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6668    Accepted Submission(s): 3008


Problem Description
Pirates have finished developing the typing software. He called Cathy to test his typing software. She is good at thinking. After testing for several days, she finds that if she types a string by some ways, she will type the key at least. But she has a bad habit that if the caps lock is on, she must turn off it, after she finishes typing. Now she wants to know the smallest times of typing the key to finish typing a string.
 

Input
The first line is an integer t (t<=100), which is the number of test case in the input file. For each test case, there is only one string which consists of lowercase letter and upper case letter. The length of the string is at most 100.
 

Output
For each test case, you must output the smallest times of typing the key to finish typing this string.
 

Sample Input
  
  
3 Pirates HDUacm HDUACM
 

Sample Output
  
  
8 8 8
Hint
The string “Pirates”, can type this way, Shift, p, i, r, a, t, e, s, the answer is 8. The string “HDUacm”, can type this way, Caps lock, h, d, u, Caps lock, a, c, m, the answer is 8 The string "HDUACM", can type this way Caps lock h, d, u, a, c, m, Caps lock, the answer is 8
 

Author
Dellenge
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   2870  2830  2845  1058  2571 
 

简单的动态规划。
先说一下题意就是用键盘输入一个字符串,里面有大小写,通过capslock和shift进行大小写切换,让你输出最小的步数。刚分开始的环境是大写没开的
分析:无外乎四种状态,上一个字符输入完大写锁定没开接下来需要输入小写,或者接下来需要输入大写;然后就是 上一个字符输入完大写锁定接下来需要输入小写,或者接下来需要输入大写;
思路:弄两个数组dpa,dpb。dpa表示大写不开的状态,dpb表示大写状态开了,接下来就是看ac代码
ac代码

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <queue>
#include <math.h>

int Min(int x,int y){
    return x<y?x:y;
}

int main()
{
	char a[105];
	int t,flag,dpa[105],dpb[105],cnt;
    int i;

	scanf("%d",&t);
	while(t--){
		scanf("%s",a+1);
//		cnt=strlen(a);
//		printf("cnt=%d\n",cnt);
		dpa[0]=0;
		dpb[0]=1;
		for(i=1;a[i]!='\0';i++){
            if(a[i]>='a' && a[i]<='z'){
                dpa[i]=Min(dpa[i-1]+1,dpb[i-1]+2);//需要输入小写,灯没亮直接输入,灯亮了shift+字母
                dpb[i]=Min(dpa[i-1]+2,dpb[i-1]+2);//需要输入小写,灯没亮输入完开灯,灯亮着shift+字母
            }
			else if(a[i]>='A' && a[i]<='Z'){
                dpa[i]=Min(dpa[i-1]+2,dpb[i-1]+2);//需要输入大写,灯不要亮shift+字母,灯亮了直接字母在关灯
                dpb[i]=Min(dpa[i-1]+2,dpb[i-1]+1);//需要输入大写,灯不亮开灯+字母,灯亮了直接字母
            }
		}
		printf("%d\n",Min(dpa[i-1],dpb[i-1]+1));//记得关灯
	}

	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值