Arbitrage POJ - 2240 (spfa 初体验)

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent. 

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not. 

Input

The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible. 
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".

Sample Input

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

Sample Output

Case 1: Yes
Case 2: No

此题标准的bellman 算法判断负环

我使用了spfa 在此中并没有体验到spfa的优化效果

之前在我认为bellman判断负环 松弛n次还是n-1无伤大雅

结果在此题因为这个wa了 此题需要n次

上传作为spfa的模板(略有变形)

#include<cstdio>
#include<algorithm>
#include<queue>
#include<string>
#include<iostream>
#include<list>
#include<stack>
#include<deque>
#include<cstring>
#include<cmath>
#include<map>
using namespace std;
struct node
{
    int to;
    double w;
}a[1005];
int first[1005];
int nex[1005];
int vis[1005];
map<string ,int> mp;
queue <int> q;
double dis[35];
int oq[35];
int m,n;
bool spfa(int x)
{
    while(q.size()) q.pop();
    int tmp;
    q.push(x);
    vis[x]=1;
    dis[x]=1;
    while(q.size())
    {
        tmp=q.front();
        //cout<<tmp<<endl;
        q.pop();
        vis[tmp]=0;
        oq[tmp]++;
        if(oq[tmp]>=n) return true;
        for(int i=first[tmp];i!=-1;i=nex[i])
        {
            //cout<<i<<endl;
            if(dis[tmp]*a[i].w>dis[a[i].to])
            {
                dis[a[i].to]=dis[tmp]*a[i].w;
                if(vis[a[i].to]==0)
                {
                    vis[a[i].to]=1;
                    q.push(a[i].to);
                }
            }
        }

    }
    if(dis[x]>1) return true;
    else
    return false;
}
int main()
{
    string tmp1;
    string tmp2;
    double tmp3;
    int tmp4;
    int tmp5;
    int cas=0;
    while(~scanf("%d",&n))
    {
        if(n==0) break;
        cas++;
        mp.clear();
        memset(first,-1,sizeof(first));
        memset(nex,-1,sizeof(nex)) ;
        for(int i=1;i<=n;i++)
        {
            cin>>tmp1;
            mp[tmp1]=i;
        }
        scanf("%d",&m);
        for(int i=1;i<=m;i++)
        {
            cin>>tmp1;
            cin>>tmp3;
            cin>>tmp2;
            tmp4=mp[tmp1];
            tmp5=mp[tmp2];
            nex[i]=first[tmp4];
            first[tmp4]=i;
            a[i].to=tmp5;
            a[i].w=tmp3;
        }
        int flag=0;
        for(int i=1;i<=n;i++)
        {
            memset(vis,0,sizeof(vis));
            memset(oq,0,sizeof(oq) );
            memset(dis,0,sizeof(dis));
            if(spfa(i)==true) {flag=1;break;}
        }
        if(flag==1) printf("Case %d: Yes\n",cas);
        else printf("Case %d: No\n",cas);

    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值