你弟弟刚刚学会写英语的一(one)、二(two)和三(three)。他在纸上写了好些一二三,可惜有些字母写错
了。已知每个单词最多有一个字母写错了(单词长度肯定不会错),你能认出他写的啥吗?
输入
第一行为单词的个数(不超过 10)。以下每行为一个单词,单词长度正确,且最多有一个字母写错。所有
字母都是小写的。
输出
对于每组测试数据,输出一行,即该单词的阿拉伯数字。输入保证只有一种理解方式。
样例输入
3
owe
too
theee
样例输出
2
3
模拟即可。
#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
using namespace std;
char a[20];
int main()
{
int t;
cin>>t;
while(t--)
{
scanf("%s",&a);
getchar();
int len;
len=strlen(a);
if(len==5)
cout<<"3"<<endl;
else
{
if((a[0]=='o'&&a[1]!='n'&&a[2]=='e')||(a[0]!='o'&&a[1]=='n'&&a[2]=='e')||(a[0]=='o'&&a[1]=='n'&&a[2]!='e')||(a[0]=='o'&&a[1]=='n'&&a[2]=='e'))
cout<<"1"<<endl;
else if((a[0]=='t'&&a[1]!='w'&&a[2]=='o')||(a[0]!='t'&&a[1]=='w'&&a[2]=='o')||(a[0]=='t'&&a[1]=='w'&&a[2]!='o')||(a[0]=='t'&&a[1]=='w'&&a[2]=='o'))
cout<<"2"<<endl;
}
}
return 0;
}