PAT 1115 Counting Nodes in a BST

1115. Counting Nodes in a BST (30)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than or equal to the node's key.
  • The right subtree of a node contains only nodes with keys greater than the node's key.
  • Both the left and right subtrees must also be binary search trees.

Insert a sequence of numbers into an initially empty binary search tree. Then you are supposed to count the total number of nodes in the lowest 2 levels of the resulting tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=1000) which is the size of the input sequence. Then given in the next line are the N integers in [-1000 1000] which are supposed to be inserted into an initially empty binary search tree.

Output Specification:

For each case, print in one line the numbers of nodes in the lowest 2 levels of the resulting tree in the format:

n1 + n2 = n

where n1 is the number of nodes in the lowest level, n2 is that of the level above, and n is the sum.

Sample Input:
9
25 30 42 16 20 20 35 -5 28
Sample Output:
2 + 4 = 6
#include <cstdio>
#include <cstring>
#include <queue>
#include <stack>
#include <iostream>
using namespace std;
struct node{
	int data;
	struct node *left;
	struct node *right;
};
struct node *Insert(struct node *tree,int num){
	if(tree==NULL){
		tree=(struct node *)malloc(sizeof(struct node));
		tree->left=tree->right=NULL;
		tree->data=num;
		return tree;
	}
	else if(num<=tree->data){
		tree->left=Insert(tree->left,num);
	}
	else{
		tree->right=Insert(tree->right,num);
	}
	return tree;
}
void Get(struct node *tree){
	int count=0;//计数每层节点数
	struct node *last;//每层最后一个节点
	queue<struct node *> q;
	stack<int> s;//每层节点数存到栈内
	if(tree==NULL){
		printf("0 + 0 = 0\n");
		return;
	}
	q.push(tree);
	last=tree;
	while(!q.empty()){
		count++;
		struct node *head=q.front();
		q.pop();
		if(head->left){
			q.push(head->left);
		}
		if(head->right){
			q.push(head->right);
		}
		if(head==last){
			last=q.back();
			s.push(count);
			count=0;
		}
	}
	int n1=s.top();
	s.pop();
	if(s.empty()){
		printf("%d + 0 = %d\n",n1,n1);
		return;
	}
	int n2=s.top();
	s.pop();
	printf("%d + %d = %d\n",n1,n2,n1+n2);
	return;
}
int main(){
	struct node *tree=NULL;
	int n,num;
	cin>>n;
	for(int i=1;i<=n;i++){
		cin>>num;
		tree=Insert(tree,num);
	}
	Get(tree);
	return 0;
}

//二维数组建立二叉搜索树
#include <cstdio>
#include <queue>
#include <stack>
#include <iostream>
using namespace std;
int tree[1005][2];
int num[1005];
int root;
void insert(int &x,int y){
	if(!x){
		x=y;
		return;
	}
	else if(num[y]>num[x]){
		insert(tree[x][1],y);
	}
	else{
		insert(tree[x][0],y);
	}
}
void dfs(int root){
	int count,last;
	queue<int> q;
	stack<int> s;
	q.push(root);
	count=0;
	last=root;
	if(!root){
		printf("0 + 0 = 0\n");  
        return;
	}
	while(!q.empty()){
		int head=q.front();
		count++;
		q.pop();
		if(tree[head][0]){
			q.push(tree[head][0]);
		}
		if(tree[head][1]){
			q.push(tree[head][1]);
		}
		if(head==last){
			s.push(count);
			count=0;
			last=q.back();
		}
	}
	if(s.size()==1){
		printf("%d + %d = %d\n",s.top(),0,s.top());
	}
	else{
		int a=s.top();
		s.pop();
		int b=s.top();
		s.pop();
		printf("%d + %d = %d\n",a,b,a+b);
	}
	return;
}
int main(){
	int n;
	cin>>n;
	for(int i=1;i<=n;i++){
		cin>>num[i];
		insert(root,i);
	}
	dfs(root);
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值