PAT-1115-二叉搜索树

1115. Counting Nodes in a BST

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than or equal to the node’s key.
The right subtree of a node contains only nodes with keys greater than the node’s key.
Both the left and right subtrees must also be binary search trees.
Insert a sequence of numbers into an initially empty binary search tree. Then you are supposed to count the total number of nodes in the lowest 2 levels of the resulting tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=1000) which is the size of the input sequence. Then given in the next line are the N integers in [-1000 1000] which are supposed to be inserted into an initially empty binary search tree.

Output Specification:

For each case, print in one line the numbers of nodes in the lowest 2 levels of the resulting tree in the format:

n1 + n2 = n

where n1 is the number of nodes in the lowest level, n2 is that of the level above, and n is the sum.

Sample Input:

9
25 30 42 16 20 20 35 -5 28

Sample Output:

2 + 4 = 6

谷歌中文翻译:

二叉搜索树(BST)递归定义为具有以下属性的二进制树:

节点的左子树仅包含键小于或等于该节点的键的节点。
节点的右子树仅包含键大于该节点的键的节点。
左和右子树都必须也是二进制搜索树。
将数字序列插入到最初为空的二叉搜索树中。 然后,您应该计算结果树的最低2个级别中的节点总数。

输入规格:

每个输入文件包含一个测试用例。 对于每种情况,第一行给出一个正整数N(<= 1000),它是输入序列的大小。 然后在下一行中给出[-1000 1000]中的N个整数,这些整数应该被插入到最初为空的二叉搜索树中。

思路:
根据题意首先得构建二叉搜索树,采用输入一个点插入并调整一个点的形式。
需要深搜把树的每个结点深度和每层有多少结点记录一下,边插入边记录可能使代码繁杂,可以拿出来dfs搜。

#include<bits/stdc++.h>
using namespace std;
const int MAX_N = 1005;

//二叉树结点构建 
struct node {
	int v;
	struct node *left;
	struct node *right;
};

int n; 
//提前分配内存
vector<int> num(MAX_N);
int maxdepth = -1;

//二叉搜索树构建 
node* insert(node *root, int v) {
	if(root == NULL) {
		//找到要插入的位置 
		root = new node();
		root->v = v;
		root->left = NULL;
		root->right = NULL;
	} else if(v <= root->v) {
		root->left = insert(root->left, v);
	} else {
		root->right = insert(root->right, v);
	}
	return root;
}

void dfs(node *root, int depth) {
	if(root == NULL) {
		maxdepth = max(depth, maxdepth);
		return ;
	}
	num[depth]++;
	dfs(root->left, depth + 1);
	dfs(root->right, depth + 1);
}

int main() {
	cin >> n;
	int temp;
	node *root = NULL;
	for(int i = 0; i < n; i++) {
		cin >> temp;
		root = insert(root, temp);
	}
	dfs(root, 0);
	cout << num[maxdepth - 1] << " + " << num[maxdepth - 2]
		 << " = " << num[maxdepth - 1] + num[maxdepth - 2];
	return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值