[2-SAT] poj 3207 Ikki's Story IV - Panda's Trick

题目链接:

http://poj.org/problem?id=3207

Ikki's Story IV - Panda's Trick
Time Limit: 1000MS Memory Limit: 131072K
Total Submissions: 8063 Accepted: 2969

Description

liympanda, one of Ikki’s friend, likes playing games with Ikki. Today after minesweeping with Ikki and winning so many times, he is tired of such easy games and wants to play another game with Ikki.

liympanda has a magic circle and he puts it on a plane, there are n points on its boundary in circular border: 0, 1, 2, …, n − 1. Evil panda claims that he is connecting m pairs of points. To connect two points, liympanda either places the link entirely inside the circle or entirely outside the circle. Now liympanda tells Ikki no two links touch inside/outside the circle, except on the boundary. He wants Ikki to figure out whether this is possible…

Despaired at the minesweeping game just played, Ikki is totally at a loss, so he decides to write a program to help him.

Input

The input contains exactly one test case.

In the test case there will be a line consisting of of two integers: n and m (n ≤ 1,000, m ≤ 500). The following m lines each contain two integers ai and bi, which denote the endpoints of the ith wire. Every point will have at most one link.

Output

Output a line, either “panda is telling the truth...” or “the evil panda is lying again”.

Sample Input

4 2
0 1
3 2

Sample Output

panda is telling the truth...

Source

[Submit]   [Go Back]   [Status]   [Discuss]

题目意思:

n个点,标号为0~n-1,顺序摆在一个圆盘的边缘上,现在给出m条边,每条边连接两个点,可以在圆盘里面或外面。判断这些边是否交叉。

解题思路:

2-SAT

把边抽象成点,如果内部连成的边抽象为i,则对应的边在外部则为i',判断任意两条边是否冲突,如果冲突的话,只能一个放在外面,一个放在里面。

i和j冲突,则建图i'->j j->i' i->j' j'->i

代码:

//#include<CSpreadSheet.h>

#include<iostream>
#include<cmath>
#include<cstdio>
#include<sstream>
#include<cstdlib>
#include<string>
#include<string.h>
#include<cstring>
#include<algorithm>
#include<vector>
#include<map>
#include<set>
#include<stack>
#include<list>
#include<queue>
#include<ctime>
#include<bitset>
#include<cmath>
#define eps 1e-6
#define INF 0x3f3f3f3f
#define PI acos(-1.0)
#define ll __int64
#define LL long long
#define lson l,m,(rt<<1)
#define rson m+1,r,(rt<<1)|1
#define M 1000000007
//#pragma comment(linker, "/STACK:1024000000,1024000000")
using namespace std;

#define Maxn 1100
int n,m;
vector<vector<int> >myv;
int low[Maxn],dfn[Maxn],sta[Maxn],bc,sc,dep;
int in[Maxn];
bool iss[Maxn];

int x[Maxn],y[Maxn];
bool iscan(int a,int b)
{
    if(x[a]<x[b]&&(y[a]>x[b]&&y[a]<y[b]))
        return true;
    if(x[a]>x[b]&&x[a]<y[b]&&y[a]>y[b])
        return true;
    return false;
}
void tarjan(int cur)
{
    int ne;

    low[cur]=dfn[cur]=++dep;
    sta[++sc]=cur;
    iss[cur]=true;

    for(int i=0;i<myv[cur].size();i++)
    {
        ne=myv[cur][i];
        if(!dfn[ne])
        {
            tarjan(ne);
            low[cur]=min(low[cur],low[ne]);
        }
        else if(iss[ne]&&dfn[ne]<low[cur])
            low[cur]=dfn[ne];
    }
    if(low[cur]==dfn[cur])
    {
        ++bc;
        do
        {
            ne=sta[sc--];
            in[ne]=bc;
            iss[ne]=false;
        }while(ne!=cur);
    }
}

void solve()
{
    low[1]=dfn[1]=bc=sc=dep=0;
    memset(iss,false,sizeof(iss));
    memset(dfn,0,sizeof(dfn));
    for(int i=1;i<=2*m;i++)
        if(!dfn[i])
            tarjan(i);
}

int main()
{
    //freopen("in.txt","r",stdin);
   //freopen("out.txt","w",stdout);
   while(~scanf("%d%d",&n,&m))
   {
       for(int i=1;i<=m;i++)
       {
           scanf("%d%d",&x[i],&y[i]);
           if(x[i]>y[i])
                swap(x[i],y[i]);
       }
       myv.clear();
       myv.resize(m*2+10);
       for(int i=1;i<=m;i++)
       {
           for(int j=i+1;j<=m;j++)
           {
               if(iscan(i,j))
               {
                   myv[2*i].push_back(2*j-1);
                   myv[2*j-1].push_back(2*i);
                   myv[2*i-1].push_back(2*j);
                   myv[2*j].push_back(2*i-1);
               }
           }
       }
       solve();

       bool ans=true;

       for(int i=1;i<=m;i++)
       {
           if(in[2*i]==in[2*i-1])
           {
               ans=false;
               break;
           }
       }
       if(ans)
            printf("panda is telling the truth...\n");
       else
            printf("the evil panda is lying again\n");

   }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值