Atlantis POJ 1151 HDU 1542

题目链接: POJ HDU


    There are several ancient Greek texts that contain descriptions of the fabled island Atlantis. Some of these texts even include maps of parts of the island. But unfortunately, these maps describe different regions of Atlantis. Your friend Bill has to know the total area for which maps exist. You (unwisely) volunteered to write a program that calculates this quantity. 

Input

    The input file consists of several test cases. Each test case starts with a line containing a single integer n (1<=n<=100) of available maps. The n following lines describe one map each. Each of these lines contains four numbers x1;y1;x2;y2 (0<=x1<x2<=100000;0<=y1<y2<=100000), not necessarily integers. The values (x1; y1) and (x2;y2) are the coordinates of the top-left resp. bottom-right corner of the mapped area. 

    The input file is terminated by a line containing a single 0. Don’t process it.

Output

    For each test case, your program should output one section. The first line of each section must be “Test case #k”, where k is the number of the test case (starting with 1). The second one must be “Total explored area: a”, where a is the total explored area (i.e. the area of the union of all rectangles in this test case), printed exact to two digits to the right of the decimal point. 

    Output a blank line after each test case. 

Sample Input

2
10 10 20 20
15 15 25 25.5
0

Sample Output

Test case #1
Total explored area: 180.00 

题意:

给你n个矩形的坐标,要你求这n个矩形所围成的大矩形的面积.

思路:

线段树之扫描线求面积,将所有的点的横坐标离散化并且去重,如何将所有节点的纵坐标进行排序,如何从下到上开始描求面积

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<iostream>
using namespace std;

#define lson cur<<1,l,mid
#define rson cur<<1|1,mid+1,r
const int maxn = 4500;

struct ss{
    double lx,rx,y;
    int tag;//边标记分别为1和-1,表示此线是入边和出边
    ss(){};
    ss (double xx,double xy,double xk, int t){
    lx = xx;rx = xy;y = xk;tag = t;};
    bool operator <(const ss &q)const{
    return y < q.y;
    }
}a[maxn];
double x[maxn];
double sum[maxn];
int flag[maxn];//懒惰标记

void pushup(int cur, int l, int r){
    if(flag[cur]) sum[cur] = x[r+1] - x[l];//更新区间线段长度
    else if(l ==r) sum[cur] = 0;
    else sum[cur] = sum[cur<<1] + sum[cur<<1|1];
}

void update(int cur, int l,int r, int ll,int rr,int v){
    if(ll <= l && rr>= r){
        flag[cur] += v;
        pushup(cur,l,r);
        return ;
    }
    int mid = (l + r)>> 1;
    if (mid >= ll) update(lson,ll,rr,v);
    if (mid < rr) update(rson,ll,rr,v);
    pushup(cur,l,r);
}

int main(){
    int n;
    int kase = 0;
    while(scanf("%d", &n) ,n){
        int num = 0;
        memset(flag,0,sizeof(flag));
        memset(sum,0,sizeof(sum));
        for(int i = 1; i <= n;++i){
            double a1,a2,b1,b2;
            scanf("%lf %lf %lf %lf", &a1, &b1, &a2, &b2);
            a[++num] = ss(a1,a2,b1,1);
            x[num] = a1;//离散化x轴坐标
            a[++num] = ss(a1,a2,b2,-1);
            x[num] = a2;
        }sort(x+1,x+1+num);//排序
        sort(a+1,a+1+num);
        int k = 1;double ans = 0;
        for(int i = 2; i<= num; ++i)
            if(x[i] != x[i+1])
                x[++k] = x[i];//去重
        for(int i = 1; i < num; ++i){
            int l = lower_bound(x+1,x+1+k,a[i].lx) - x;//查找x轴坐标所在的位置
            int r = lower_bound(x+1,x+1+k,a[i].rx) - x - 1;
            update(1,1,k,l,r,a[i].tag);
            ans += sum[1] * (a[i+1].y - a[i].y);
        }printf("Test case #%d\n", ++kase);
        printf("Total explored area: %.2f\n\n",ans);
    }return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值