More is better HDU - 1856

题目链接:点我


 Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.

Input

The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)

Output

The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.

Sample Input

4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8

Sample Output

4
2

Hint

A and B are friends(direct or indirect), B and C are friends(direct or indirect), 
then A and C are also friends(indirect).

 In the first sample {1,2,5,6} is the result.
In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.

题意:

王先生想选取一些人帮助他做实验,并且人数越多越好,但他只能选取一个人,但与选取那个人是直接或者简介朋友关系的人都要留小,问最多的人数是多少.

思路:

带权并查集, 我们只需要选取权值最大的那个就可以了,每次合并操作时,将他们的权值相加,

代码:

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<iostream>
using namespace std;

const int maxn = 1e7 + 10;
int ran[maxn];
int f[maxn];
bool vis[maxn];

int getf(int x){
    if(f[x] == x) return x;
    int tmp = f[x];
    f[x] = getf(f[x]);
    return f[x];
}

void Merge(int x, int y){
    int t1 = getf(x);
    int t2 = getf(y);
    if( t1 != t2){
        f[t2] = t1;
        ran[t1] += ran[t2];//合并操作,权值相加
    }
}

int main(){
    int n;
    while(scanf("%d", &n) != EOF){
        if(n == 0){
            printf("1\n");
            continue;
        }
        int ans = 0;
        memset(ran,0,sizeof(ran));
        for(int  i = 1; i <maxn; ++i)
            f[i] = i,ran[i] = 1;//初始化每个权值为 1 ,
        memset(vis,false,sizeof(vis));
        while(n--){
            int x, y;
            scanf("%d %d", &x, &y);
            Merge(x,y);
            vis[x] = vis[y] = true;
        }
        for(int  i = 1; i < maxn; ++i)
            if(vis[i] && f[i] == i)
                ans = max(ans,ran[i]);
        printf("%d\n",ans );
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值