Cows POJ - 2481

题目链接:点我


    Farmer John's cows have discovered that the clover growing along the ridge of the hill (which we can think of as a one-dimensional number line) in his field is particularly good. 

    Farmer John has N cows (we number the cows from 1 to N). Each of Farmer John's N cows has a range of clover that she particularly likes (these ranges might overlap). The ranges are defined by a closed interval [S,E]. 

    But some cows are strong and some are weak. Given two cows: cow i and cow j, their favourite clover range is [Si, Ei] and [Sj, Ej]. If Si <= Sj and Ej <= Ei and Ei - Si > Ej - Sj, we say that cow i is stronger than cow j. 

    For each cow, how many cows are stronger than her? Farmer John needs your help!

Input

    The input contains multiple test cases. 
    For each test case, the first line is an integer N (1 <= N <= 10 5), which is the number of cows. Then come N lines, the i-th of which contains two integers: S and E(0 <= S < E <= 10 5) specifying the start end location respectively of a range preferred by some cow. Locations are given as distance from the start of the ridge. 

    The end of the input contains a single 0.

Output

    For each test case, output one line containing n space-separated integers, the i-th of which specifying the number of cows that are stronger than cow i. 

Sample Input

3
1 2
0 3
3 4
0

Sample Output

1 0 0

Hint

    Huge input and output,scanf and printf is recommended.

题意:

给你一系列的区间,要你求,此区间被多少个区间包含.

思路:

树状数组,对于所有的区间按照右端点进行升序排序,那么我们每次只需要用树状数组查询此区间的左端前面共有多个点,如何将左端点加入即可.

代码:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;

struct ss{
    int s,e,index;
    bool operator < (const ss &q){
    if(e == q.e)
        return s < q.s;
    return e > q.e;
    }
}a[500000+10];

int num[500000+10];
int sum[500000+10];
int n;

int lowbit(int x){
return x&-x;
}

void add(int x){
    while(x <= n){
        sum[x] ++;
        x += lowbit(x);
    }
}

int su(int x){
    int ans = 0;
    while(x > 0){
        ans += sum[x];
        x -= lowbit(x);
    }
    return ans;
}

int main(){
    while(scanf("%d", &n) != EOF && n){
        for(int i = 1; i <= n; ++ i){
            scanf("%d %d", &a[i].s, &a[i].e);
            a[i].index = i;//需要记录下标
        }
        memset(sum, 0, sizeof(sum));
        memset(num, 0, sizeof(num));
        sort(a + 1, a + 1 + n);
        num[a[1].index] = 0;//第一个点不会被任何点包含
        add(a[1].s + 1);
        for(int  i = 2; i <= n; ++ i){
            if(a[i].s == a[i-1].s && a[i].e == a[i-1].e)
            //如果连个区间重合,那么他们的被包含数目也应该相等
                num[a[i].index] = num[a[i-1].index];
            else num[a[i].index] = su(a[i].s + 1);
            add(a[i].s + 1);
        }
        for(int i = 1; i < n; ++i)
            printf("%d ",num[i]);
        printf("%d\n",num[n]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值