Ultra-QuickSort POJ - 2299

题目链接:点我


    In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. 

这里写图片描述

For the input sequence 
9 1 0 5 4 ,

Ultra-QuickSort produces the output 
0 1 4 5 9 .

    Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

    The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

    For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0

题意:

求逆序对数.

思路:

树状数组求逆序对数,每次只需要查询第i个数前面出现的数有多少个比它小,如何用i减去,就得到了逆序对数.

代码:

#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<iostream>
using namespace std;

const int maxn = 500000+10;
int n;
long long a[maxn];
int b[maxn];
struct ss{
    int x, y;
    bool operator < (const ss &p){
    return x < p.x;
    }
}q[maxn];

int lowbit(int x){
    return x&-x;
}

int sum(int x){
    int ans = 0;
    while(x > 0){
        ans += a[x];
        x -= lowbit(x);
    }
    return ans;
}

void add(int x){
    while(x <= n){
        ++ a[x];
        x += lowbit(x);
    }
}

int main(){
    while(scanf("%d", &n), n){
        long long  ans = 0;
        memset(a, 0, sizeof(a));
        for(int i = 1; i <= n; ++ i){
            scanf("%d", &q[i].x);
            q[i].y = i;
        }
        sort(q + 1, q + 1 + n);
        for(int i = 1; i <= n; ++i) b[q[i].y] = i;
        memset(a, 0, sizeof(a));
        for(int  i = 1; i <= n; ++i){
            ans += i - sum(b[i])-1;
            add(b[i]);
        }
        printf("%lld\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值