Let it Bead POJ - 2409 Polya定理

[题目链接](http://poj.org/problem?id=2409)


这里写图片描述

"Let it Bead" company is located upstairs at 700 Cannery Row in Monterey, CA. As you can deduce from the company name, their business is beads. Their PR department found out that customers are interested in buying colored bracelets. However, over 90 percent of the target audience insists that the bracelets be unique. (Just imagine what happened if two women showed up at the same party wearing identical bracelets!) It's a good thing that bracelets can have different lengths and need not be made of beads of one color. Help the boss estimating maximum profit by calculating how many different bracelets can be produced.

A bracelet is a ring-like sequence of s beads each of which can have one of c distinct colors. The ring is closed, i.e. has no beginning or end, and has no direction. Assume an unlimited supply of beads of each color. For different values of s and c, calculate the number of different bracelets that can be made. 

Input

Every line of the input file defines a test case and contains two integers: the number of available colors c followed by the length of the bracelets s. Input is terminated by c=s=0. Otherwise, both are positive, and, due to technical difficulties in the bracelet-fabrication-machine, cs<=32, i.e. their product does not exceed 32. 

Output

For each test case output on a single line the number of unique bracelets. The figure below shows the 8 different bracelets that can be made with 2 colors and 5 beads. 

Sample Input

1 1
2 1
2 2
5 1
2 5
2 6
6 2
0 0

Sample Output

1
2
3
5
8
13
21

题意:

给定M种颜色的珠子,每种颜色珠子的个数均不限,将这些珠子做成长度为N的项链。

问能做成多少种不重复的项链,最后的结果不会超过int类型数据的表示范围。并且两

条项链相同,当且仅当两条项链通过旋转或是翻转后能重合在一起,且对应珠子的颜

色相同。

思路:

Polya定理

题目有两种转置方式:

  1. 旋转转置: 这里我们需要求出所有的循环节数, 最后答案就等于 1n(mp1mp2) , pi 为循环节,所以我们只需要找到循环节就可以了, 那么如何求解循环节呢,假设 每 i 个节点的颜色一样, 那么循环节是gcd( n, i);

    2.翻转置换: 假设 n 为奇数, 那么 mn/2+1n 种.
    如果n为偶数,那么此时有两种翻转, 一种是以两个点对称, 另一种是以两条边对称 , 那么有 mn2+1n2+mn2n2 种.

代码:

#include<iostream>
using namespace std;

typedef long long LL;

LL qpow( LL x, LL n){
    LL ans = 1;
    while(n){
        if(n&1) ans *= x;
        x *= x;
         n >>= 1;
    }return ans;
}

int gcd(int a, int b){
    return b ? gcd(b, a % b) : a;
}

int main(){
    LL c, s;
    ios::sync_with_stdio(false);
    while(cin >> c >> s&&(c || s)){
int xxx = 100 / 0;
        LL ans =0;
        for(int i = 1; i <= s; ++i)
            ans += qpow(c, gcd(s, i));
        if (s&1)
            ans += qpow(c, s/2 + 1) * s;
        else ans += (qpow(c,s/2 + 1) + qpow(c, s / 2)) * (s / 2);
        ans /= 2 * s;
        cout<<ans<<endl;
    }return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值