poj 2352 入门树状数组

点击打开链接


Stars
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 49310 Accepted: 21282

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0
题意: 按照y的升序给出星星的坐标,一个星星如果有a个星星的x和y均小于或等于这个星星的坐标,那么这个星星的等级就是a,
依次求等级为0到n-1的星星个数
由于数据是按照y升序给出的,因此计算的时候可以完全不管y,只对x进行研究,求某个星星等级时,只需计算已经给出的星星坐标中有几个星星的x是小于这个星星的x就行了,可用树状数组进行维护和计算。
#include<stdio.h>
#include<string.h>
int num[50000];
int vis[20000];
int sum(int i)
{
	int ans=0;
	while(i>0)
	{
		ans+=num[i];
		i-=i&(-i); 
	}
	return ans;
}
void add(int i,int n)
{
	while(i<=n)
	{
		num[i]++;
		i+=i&(-i);
	}
}
int main()
{
	int n;
	while(~scanf("%d",&n))
	{
		int x,y,i;
		memset(vis,0,sizeof(vis));
		memset(num,0,sizeof(num));
		for(i=0;i<n;i++)
		{
			scanf("%d%d",&x,&y);
			x++;  //记得要加1,因为给出的数据有0,对0计算会死循环 
			vis[sum(x)]++;
			add(x,40000);
		}
		for(i=0;i<n;i++)
		printf("%d\n",vis[i]);
	}
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

长沙橘子猫

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值