poj 2155 二维线段树或树状数组入门

点击打开链接

Matrix
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 29520 Accepted: 10781

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N). 

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions. 

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2). 
2. Q x y (1 <= x, y <= n) querys A[x, y]. 

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case. 

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above. 

Output

For each querying output one line, which has an integer representing A[x, y]. 

There is a blank line between every two continuous test cases. 

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1

题意:C:输入一个矩形的左上点和右下点,改变矩形内所有点状态,若是0就改为1,若是1就改为0,Q:查询该点是1还是0

这是个二维树状数组模板题,也是个二维线段树模板题,贴代码

二维树状数组:

#include<stdio.h>
#include<string.h>
#define maxn 1010
int c[maxn][maxn];
int n;
void update(int x,int y)
{
	for(int i=x;i<=n;i+=i&(-i))
	for(int j=y;j<=n;j+=j&(-j))
	c[i][j]++;
}
int query(int x,int y)
{
	int ans=0;
	for(int i=x;i>0;i-=i&(-i))
	for(int j=y;j>0;j-=j&(-j))
	ans+=c[i][j];
	return ans;
}
int main()
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
		int m,x1,x2,y1,y2,i,j;
		char ch[2];
		scanf("%d%d",&n,&m);
		memset(c,0,sizeof(c));
		while(m--)
		{
			scanf("%s",ch);
			if(ch[0]=='C')
			{
				scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
				update(x1,y1);
				update(x2+1,y1);
				update(x1,y2+1);
				update(x2+1,y2+1);
			}
			else
			{
				scanf("%d%d",&x1,&y1);
				int temp=query(x1,y1);
				if(temp&1)
				printf("1\n");
				else
				printf("0\n");
			}
		}
		printf("\n");
	}
}
二维线段树:

#include<stdio.h>
#include<string.h>
#define maxn 1010
int seg[3*maxn][3*maxn];
int ans;
int n;
void query2(int l,int r,int node,int k,int y)
{
	ans+=seg[k][node];
	if(l==r)
	return;
	int m=(l+r)/2;
	if(m>=y)
	query2(l,m,node*2,k,y);
	else
	query2(m+1,r,node*2+1,k,y);
}
void query1(int l,int r,int node,int x,int y)
{
	query2(1,n,1,node,y);
	if(l==r)
	return;
	int m=(l+r)/2;
	if(m>=x)
	query1(l,m,node*2,x,y);
	else
	query1(m+1,r,node*2+1,x,y);
}
void update2(int l,int r,int node,int k,int y1,int y2)
{
	if(l>=y1&&r<=y2)
	{
		seg[k][node]++;
		return;
	}
	int m=(l+r)/2;
	if(m<y1)
	update2(m+1,r,node*2+1,k,y1,y2);
	else if(m>=y2)
	update2(l,m,node*2,k,y1,y2);
	else
	{
		update2(m+1,r,node*2+1,k,y1,y2);
		update2(l,m,node*2,k,y1,y2);
	}	
}
void update1(int l,int r,int node,int x1,int x2,int y1,int y2)
{
	if(l>=x1&&r<=x2)
	{
		update2(1,n,1,node,y1,y2);
		return;
	}
	int m=(l+r)/2;
	if(m<x1)
	update1(m+1,r,node*2+1,x1,x2,y1,y2);
	else if(m>=x2)
	update1(l,m,node*2,x1,x2,y1,y2);
	else
	{
		update1(m+1,r,node*2+1,x1,x2,y1,y2);
		update1(l,m,node*2,x1,x2,y1,y2);
	}
}
int main()
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
		int m,x1,x2,y1,y2;
		char ch[2];
		memset(seg,0,sizeof(seg));
		scanf("%d%d",&n,&m);
		while(m--)
		{
			scanf("%s",ch);
			if(ch[0]=='Q')
			{
				scanf("%d%d",&x1,&y1);
				ans=0;
				query1(1,n,1,x1,y1);
				if(ans&1)
				printf("1\n");
				else
				printf("0\n");
			}
			else
			{
				scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
				update1(1,n,1,x1,x2,y1,y2);
			}
		}
		printf("\n");
	}
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

长沙橘子猫

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值