poj 3928 难度:一般

点击打开链接

Ping pong
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3541 Accepted: 1272

Description

N(3<=N<=20000) ping pong players live along a west-east street(consider the street as a line segment). Each player has a unique skill rank. To improve their skill rank, they often compete with each other. If two players want to compete, they must choose a referee among other ping pong players and hold the game in the referee's house. For some reason, the contestants can't choose a referee whose skill rank is higher or lower than both of theirs. The contestants have to walk to the referee's house, and because they are lazy, they want to make their total walking distance no more than the distance between their houses. Of course all players live in different houses and the position of their houses are all different. If the referee or any of the two contestants is different, we call two games different. Now is the problem: how many different games can be held in this ping pong street?

Input

The first line of the input contains an integer T(1<=T<=20), indicating the number of test cases, followed by T lines each of which describes a test case. 
Every test case consists of N + 1 integers. The first integer is N, the number of players. Then N distinct integers a1, a2 ... aN follow, indicating the skill rank of each player, in the order of west to east. (1 <= ai <= 100000, i = 1 ... N).

Output

For each test case, output a single line contains an integer, the total number of different games. 

Sample Input

1 
3 1 2 3

Sample Output

1
题意:按顺序有N个乒乓球运动员,每个人有一个对应的ai值,每三个人可以组成比赛,要求是三个人的中间的人(裁判)的ai值也要排中间,问可以组成多少次比赛。

思路:其实很简单,假设我设置第x人裁判,假设裁判前面有ci个人ai值比他小,那就有x-1-ci个人比他大,裁判后面有di个人的ai值比他小,那么有n-x-di个人的ai值比他大,即第x人为裁判共有:ci*(n-x-di)+(x-1-ci)*di场比赛,可用树状数组求每个人的ci和di。

#include<stdio.h>
#include<string.h>
#define maxn 100001
#define low(i) i&(-i)
int ci[maxn],di[maxn];
int c[maxn];
int a[maxn];
int sum(int i)
{
	int ans=0;
	while(i>0)
	{
		ans+=c[i];
		i-=low(i);
	}
	return ans;
}
void add(int i)
{
	while(i<=maxn)
	{
		c[i]++;
		i+=low(i);
	}
}
int main()
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
		int i,n;
		scanf("%d",&n);
		memset(c,0,sizeof(c));
		for(i=1;i<=n;i++)
		{
			scanf("%d",&a[i]);
			ci[i]=sum(a[i]);
			add(a[i]);
		}
		memset(c,0,sizeof(c));
		for(i=n;i>=1;i--)
		{
			di[i]=sum(a[i]);
			add(a[i]);
		}
		int t1,t2;
		long long ans=0;
		for(i=2;i<n;i++)
		{
			t1=ci[i]*(n-i-di[i]);
			t2=(i-1-ci[i])*di[i];
			ans+=(t1+t2);
		}
		printf("%lld\n",ans);
	}
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

长沙橘子猫

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值