poj 1182 中等

点击打开链接

食物链
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 77943 Accepted: 23202

Description

动物王国中有三类动物A,B,C,这三类动物的食物链构成了有趣的环形。A吃B, B吃C,C吃A。 
现有N个动物,以1-N编号。每个动物都是A,B,C中的一种,但是我们并不知道它到底是哪一种。 
有人用两种说法对这N个动物所构成的食物链关系进行描述: 
第一种说法是"1 X Y",表示X和Y是同类。 
第二种说法是"2 X Y",表示X吃Y。 
此人对N个动物,用上述两种说法,一句接一句地说出K句话,这K句话有的是真的,有的是假的。当一句话满足下列三条之一时,这句话就是假话,否则就是真话。 
1) 当前的话与前面的某些真的话冲突,就是假话; 
2) 当前的话中X或Y比N大,就是假话; 
3) 当前的话表示X吃X,就是假话。 
你的任务是根据给定的N(1 <= N <= 50,000)和K句话(0 <= K <= 100,000),输出假话的总数。 

Input

第一行是两个整数N和K,以一个空格分隔。 
以下K行每行是三个正整数 D,X,Y,两数之间用一个空格隔开,其中D表示说法的种类。 
若D=1,则表示X和Y是同类。 
若D=2,则表示X吃Y。

Output

只有一个整数,表示假话的数目。

Sample Input

100 7
1 101 1 
2 1 2
2 2 3 
2 3 3 
1 1 3 
2 3 1 
1 5 5

Sample Output

3

这个题我不会写,参考了大神的思路:http://blog.csdn.net/niushuai666/article/details/6981689 飘过的小牛,写的很详细很好,是并查集比较高级的应用。

#include<stdio.h>
#include<string.h>
struct node
{
	int pre;
	int relation;
}p[50001];
void clear(int n)
{
	for(int i=0;i<=n;i++)
	{
		p[i].pre=i;
		p[i].relation=0;	
	}
}
int find(int x)
{
	if(p[x].pre==x)
	return x;
	int temp=p[x].pre;
	p[x].pre=find(temp);
	p[x].relation=(p[x].relation+p[temp].relation)%3;
	return p[x].pre;
}
int main()
{
	int n,k;
	scanf("%d%d",&n,&k);	
	int D,x,y,ans=0;
	clear(n);
	while(k--)
	{
		scanf("%d%d%d",&D,&x,&y);
		if(x>n||y>n)
		{
			ans++;
			continue;
		}
		if(D==2&&x==y)
		{
			ans++;
			continue;
		}
		int t1=find(x);
		int t2=find(y);
		if(t1!=t2)
		{
			p[t2].pre=t1;
			int temp=p[x].relation-p[y].relation+3;
			p[t2].relation=(temp+D-1)%3;
		}
		else
		{
			if(D==1&&p[x].relation!=p[y].relation)
			ans++;
			int temp=p[x].relation-p[y].relation+3;
			if(D==2&&temp%3!=2)
			ans++;
		}
	}
	printf("%d\n",ans);	
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

长沙橘子猫

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值