8.1-line_up-dp最长递增子序列

Description
In the army, a platoon is composed by n soldiers. During the morning inspection, the soldiers are
required to line up in a straight line in front of the captain. The captain is not satisfied with the way
his soldiers are ranked, because the soldiers are standing in order by their code number: 1 , 2 , 3 ,
…, n , but they are not ranked by their height. The captain asks some soldiers to get out of the line,
and other soldiers remain in the line without changing their position. The remaining soldiers form a
new line where each soldier can see at least one of the line’s end (left or right).
Given the height of each soldier, determines the minimum number of soldiers which have to get out
of line.
Note:
A soldier can see an end, if all the soldiers between him and that end are shorter than him.
Input
The input contains two lines. The first line is the number of the soldiers n. The second line is a
sequence of n floating-point numbers with at most 5 digits precision and every two consecutive
numbers are separated by a space. The k-th number from this line represents the height of the
soldier who has the code k (1 <= k <= n).
There are some restrictions:
1. 2 <= n <= 1000
2. the height are floating numbers from the interval [0.5, 2.5]
Output
The output is the number of the soldiers who have to get out of the line.
Sample Input
8
1.86 1.86 1.30621 2 1.4 1 1.97 2.2
Sample Output
4

动态规划求 正反的 最长递增子序列
数组的每一位表示以此位结尾的最长递增串的长度,每次需要遍历所有的可能。

注意点在于:
实际上是找到一个梯形而不是三角形,代码的45-54行就是要说明这个
题目描述不准确,注意是梯形。
第33行的循环是因为有这种情况:。。。23 12 45 不确定是选12这条路还是23这条路。

#include<iostream>
using namespace std;
int a[1001]={0};//第i个值表示首节点与第i个元素(一定含第i个元素)的单调递增子序列的最大个数 
int b[1001]={0};//第i个值表示第i个元素(一定含第i个元素)与尾节点的单调递减子序列的最大个数 
float height[1001];
int main()
{
    int n;
    cin>>n;
    for(int i=1;i<=n;i++)
    {
        cin>>height[i];
    }
    //dp
    for(int i=1;i<=n;i++)
    {
        a[i]=1;
        for(int j=1;j<i;j++)
        {
            if(height[i]>height[j])
            {
                if(a[j]+1>a[i])
                {
                    a[i]=a[j]+1;
                }
            }
        }
    } 
    //dp
    for(int i=n;i>=1;i--)
    {
        b[i]=1;
        for(int j=i+1;j<=n;j++)
        {
            if(height[i]>height[j])
            {
                if(b[j]+1>b[i])
                {
                    b[i]=b[j]+1;
                }
            }
        }
    }
    int curr=0;
    for(int i=1;i<n;i++)
    {
        for(int j=i+1;j<=n;j++)
        {
            if(a[i]+b[j]>curr)
            {
                curr=a[i]+b[j];
            }
        }
    }
    cout<<n-curr<<endl;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值