POJ1753 Flip Game(位压+BFS)

3 篇文章 0 订阅

原题链接:点击打开链接

Flip Game
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 40857 Accepted: 17742

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules: 
  1. Choose any one of the 16 pieces. 
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

Consider the following position as an example: 

bwbw 
wwww 
bbwb 
bwwb 
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become: 

bwbw 
bwww 
wwwb 
wwwb 
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal. 

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4

Source


题意就是让我们选一个格子翻棋,转换颜色,并对其上下左右(如果有的话)也进行翻转操作。问有没有使得所有棋子为白色或黑色的状态,如果有,输出最小步数,没有,则输出“Impossible”。

主要思想就是把16个格子的翻转操作进行枚举,并以位形式表示,最后转成十进制打表。如:

bbbb

bbbb

bbbb

bbbb

则状态为1111 1111 1111 1111   

假设我们对此状态的最左上角翻转,则会变成:

wwbb

wbbb

bbbb

bbbb

对应状态为0011 0111 1111 1111

注意到1^1=0,0^1=1  所以我们将某位对1异或操作来模拟翻转操作

设定好初始状态后,进行BFS+QUEUE枚举状态

总状态数不会超过65536种状态,由于可能会有重复的情况,所以用visit记录是否经历过当前状态。


#include <cstdio>  
#include <cstring>  
#include <cmath>  
#include <cstdlib>  
#include <algorithm>  
#include <queue>  
#include <stack>  
#include <map>  
#include <vector>
#include<iostream>
#define INF 0x3f3f3f3f  
#define eps 1e-4  
#define MAXN (100+10)  
#define MAXM (1000000)  
#define CLR(a, b) memset(a, (b), sizeof(a))  
#define MOD 100000007  
#define LL long long  
#define lson node<<1, l, mid  
#define rson node<<1|1, mid+1, r   
using namespace std;
int n, m;
bool visit[65536];
struct Node
{
	int state, step;
};

int Flip[16] = { 51200,58368,29184,12544,35968,20032,10016,4880,2248,1252,626,305,140,78,39,19 };

int bfs(int state) {
	memset(visit, false, sizeof(visit));
	queue <Node> q;
	Node cur, next;
	cur.state = state;
	cur.step = 0;
	visit[state] = true; 
	q.push(cur);
	while(!q.empty()) {
		cur = q.front();
		q.pop();
		if (cur.state == 0 || cur.state == 0xffff)
			return cur.step;
		for (int i = 0; i < 16; ++i) {
			next.state = cur.state^Flip[i];
			next.step = cur.step + 1;
			if( visit[next.state])
				continue;
			if (next.state == 0 || next.state == 0xffff)
				return next.step;
			q.push(next);
			visit[next.state] = true;
		}
	}
	return -1;
}

int main() {
	char fl[5][5];
	int t = 0,state,ans;
	while (scanf("%s",fl[0]) != EOF) {
		
		for (int i = 1; i < 4; ++i)
			scanf("%s", fl[i]);
		state = 0;
		for(int i=0;i<4;++i)
			for (int j = 0; j < 4; ++j) {
				state <<= 1;
				if (fl[i][j] == 'b')state += 1;
			}
		ans = bfs(state);
		if (ans == -1)
			cout << "Impossible";
		else
			cout << ans << endl;

	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值