Building Shops (HDU - 6024 )

Problem Description

HDU’s n classrooms are on a line ,which can be considered as a number line. Each classroom has a coordinate. Now Little Q wants to build several candy shops in these n classrooms.

The total cost consists of two parts. Building a candy shop at classroom i would have some cost ci. For every classroom P without any candy shop, then the distance between P and the rightmost classroom with a candy shop on P's left side would be included in the cost too. Obviously, if there is a classroom without any candy shop, there must be a candy shop on its left side.

Now Little Q wants to know how to build the candy shops with the minimal cost. Please write a program to help him.

 

 

Input

The input contains several test cases, no more than 10 test cases.
In each test case, the first line contains an integer n(1≤n≤3000), denoting the number of the classrooms.
In the following n lines, each line contains two integers xi,ci(−109≤xi,ci≤109), denoting the coordinate of the i-th classroom and the cost of building a candy shop in it.
There are no two classrooms having same coordinate.

 

 

Output

For each test case, print a single line containing an integer, denoting the minimal cost.

 

 

Sample Input

 

3 1 2 2 3 3 4 4 1 7 3 1 5 10 6 1

 

 

Sample Output

 

5 11

题意,dp题,每一步有两个选择 建商店或者不建  不建的时候前面的每一步也要更新最小的情况,总之就是每走一步要求最优

的解

#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <algorithm>
#include <string.h>
#include <map>
#include <queue>
#include <stack>
#include <math.h>
#include <string>


using namespace std;
typedef long long ll;
const int INF = 0x3f3f3f3f3f3f3f3f;
const int N = 3000+7;


struct rt{
    ll u,v;
    friend bool operator < (rt c,rt d){
        return c.u<d.u;
    }
}a[N];
ll dp[N][3];
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        memset(dp,INF,sizeof(dp));
        for(int i=1;i<=n;i++)
        {
            scanf("%lld%lld",&a[i].u,&a[i].v);
        }
        sort(a+1,a+n+1);
        dp[0][1]=0;
        dp[0][0]=0;
        for(int i=1;i<=n;i++)
        {
            dp[i][1]=min(dp[i-1][0],dp[i-1][1])+a[i].v;
            ll cost = 0;
            for(int j=i-1;j>=1;j--)
            {
                cost+=(i-j)*(a[j+1].u-a[j].u);
                dp[i][0]=min(dp[i][0],dp[j][1]+cost);
            }
        }
        printf("%lld\n",dp[n][1]<dp[n][0]?dp[n][1]:dp[n][0]);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值