Building Shops HDU - 6024


HDU’s nn classrooms are on a line ,which can be considered as a number line. Each classroom has a coordinate. Now Little Q wants to build several candy shops in these nn classrooms.


The total cost consists of two parts. Building a candy shop at classroom ii would have some cost cici. For every classroom PP without any candy shop, then the distance between PP and the rightmost classroom with a candy shop on PP's left side would be included in the cost too. Obviously, if there is a classroom without any candy shop, there must be a candy shop on its left side.

Now Little Q wants to know how to build the candy shops with the minimal cost. Please write a program to help him.
Input
The input contains several test cases, no more than 10 test cases.
In each test case, the first line contains an integer n(1≤n≤3000)n(1≤n≤3000), denoting the number of the classrooms.
In the following nn lines, each line contains two integers xi,ci(−109≤xi,ci≤109)xi,ci(−109≤xi,ci≤109), denoting the coordinate of the ii-th classroom and the cost of building a candy shop in it.
There are no two classrooms having same coordinate.
Output
For each test case, print a single line containing an integer, denoting the minimal cost.
Sample Input
3
1 2
2 3
3 4
4
1 7
3 1
5 10
6 1
Sample Output
5

11



#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define INF 0x3f3f3f3f

struct node
{
    int w;
    int v;
} que[3001];

int cmp(node a,node b)
{
    return a.w<b.w;
}

long long dp[3001][2],res[3001][3001];
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        for(int i=0; i<n; i++)
            scanf("%d%d",&que[i].w,&que[i].v);
        sort(que,que+n,cmp);
        memset(dp,INF,sizeof(dp));
        for(int i=0; i<n; i++)
        {
            res[i][i]=0;
            for(int j=i+1; j<n; j++)
                res[i][j]=res[i][j-1]+que[j].w-que[i].w;
            //假设教室i建设糖果店,求出教室i到教室j之间的总距离(此时中间的教室都没有建设糖果店)
        }
        dp[0][1]=que[0].v;

        for(int i=1; i<n; i++)
        {
            dp[i][1]=min(dp[i-1][0],dp[i-1][1])+que[i].v;  //教室i建设糖果店
            for(int j=0; j<i; j++)
            {
                dp[i][0]=min(dp[i][0],dp[j][1]+res[j][i]);  //教室i不建设糖果店
            }
        }
        printf("%lld\n",min(dp[n-1][0],dp[n-1][1]));
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
好的,我可以给你一些指导来创建和使用shops数据库。 首先,你需要安装一个关系型数据库管理系统(RDBMS),例如MySQL、PostgreSQL或Microsoft SQL Server。这些RDBMS都提供了创建和管理数据库的工具。 一旦你安装了RDBMS,你可以使用SQL(结构化查询语言)来创建数据表和插入数据。下面是一个示例的SQL代码来创建一个名为“shops”的数据库: ``` CREATE DATABASE shops; ``` 接下来,你可以创建一个名为“products”的表来存储商品信息,例如商品名称、价格和库存量。下面是一个示例的SQL代码: ``` CREATE TABLE products ( id INT NOT NULL AUTO_INCREMENT, name VARCHAR(255) NOT NULL, price DECIMAL(10,2) NOT NULL, stock INT NOT NULL, PRIMARY KEY (id) ); ``` 这将创建一个名为“products”的表,其中包含四个列:id、name、price和stock。id列是自动增量的主键,确保每个商品都有一个唯一的标识符。name列存储商品名称,price列存储商品价格,stock列存储商品库存量。 一旦你创建了“products”表,你可以使用INSERT语句向表中插入数据。例如,下面是一个示例的SQL代码来插入一些商品信息: ``` INSERT INTO products (name, price, stock) VALUES ('T-shirt', 19.99, 100), ('Jeans', 49.99, 50), ('Sneakers', 79.99, 25); ``` 这将向“products”表中插入三个商品,分别是T-shirt、Jeans和Sneakers,每个商品都有一个价格和库存量。 一旦你向表中插入了数据,你可以使用SELECT语句来查询数据。例如,下面是一个示例的SQL代码来查询所有商品的名称和价格: ``` SELECT name, price FROM products; ``` 这将返回一个结果集,其中包含所有商品的名称和价格。 当然,这只是一个简单的示例,你可以根据自己的需求创建更复杂的表和查询。希望这些指导可以帮助你创建和使用shops数据库。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值