PAT-1015

9 篇文章 0 订阅
6 篇文章 0 订阅


1015. Reversible Primes (20)

题目地址:http://pat.zju.edu.cn/contests/pat-practise/1015

A reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (< 105) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line "Yes" if N is a reversible prime with radix D, or "No" if not.

Sample Input:
73 10
23 2
23 10
-2
Sample Output:
Yes
Yes
No
 
#if 1

#include <stdio.h>
#include <math.h>


int ArrayToInt(int a[],int n,int base)
{
	int sum;
	int i;

	for(sum = 0,i  = 0;i < n;i++)
		sum = sum*base + a[i];
	
	return sum;
}

int IntToArrray(int a[],int n,int base)
{
	int i = 0;
	
	while(n)
	{
	 a[i++] = n%base;
	 n = n/base;
	}
	return i;
}

int IsPrime(int n)
{
	int i;
	int flag;
	flag = 1;

	if(n == 1|| n == 0)
		flag = 0;

	for(i = 2;i <= sqrt(n);i++)
	{
		if(n%i == 0)
		{
			flag = 0;
			break;
		}
	}
	return flag;
}

int main(int argc,char *argv[])
{
	int n;
	int base;
	int arr[100];
	int len;
	int reverseNum;

	freopen( "D:\\Chengsq\\in.txt" , "r" ,stdin);
    freopen( "D:\\Chengsq\\out.txt", "w" ,stdout);

	while(scanf("%d",&n) !=EOF && (n >= 0))
	{
		scanf("%d",&base);
		if(n == 0)
			printf("No\n");
		else
		{
			len = IntToArrray(arr,n,base);
			reverseNum = ArrayToInt(arr,len,base);

			if(IsPrime(reverseNum)&&IsPrime(n))
				printf("Yes\n");
			else
				printf("No\n");
		}

	}
	return 0;
}

#endif

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值