PAT-1040

9 篇文章 0 订阅
6 篇文章 0 订阅

1040. Longest Symmetric String

题目地址:http://pat.zju.edu.cn/contests/pat-practise/1040

Given a string, you are supposed to output the length of the longest symmetric sub-string. For example, given "Is PAT&TAP symmetric?", the longest symmetric sub-string is "s PAT&TAP s", hence you must output 11.

Input Specification:

Each input file contains one test case which gives a non-empty string of length no more than 1000.

Output Specification:

For each test case, simply print the maximum length in a line.

Sample Input:
Is PAT&TAP symmetric?
Sample Output:
11
 
 
#if 1

#include <stdio.h>
#include <string.h>

#define  MAXN  (1000+1)

int MaxOddSym(char s[],int axis)
{
	int j;
	int CurCnt;
	for(CurCnt = 0,j = 0;j <= axis;j++)
		{
			if(s[axis-j] != s[axis+j])
				break;
			else	
				CurCnt++;
		}
	return CurCnt*2-1;
}

int MaxEvenSym(char s[],int axis)
{
	int j;
	int CurCnt;
	for(CurCnt = 0,j = 0;j <= axis;j++)
		{
			if(s[axis-j] != s[axis+j+1])
				break;
			else	
				CurCnt++;
		}
	return CurCnt*2;
}

int FindLongestSymStr(char s[])
{
	int max,len,CurMax; 
	int i,j;
	len = strlen(s);
	
	for(max = 0,i = 0;i < len-(max)/2;i++)
	{
		CurMax = MaxOddSym(s,i) > MaxEvenSym(s,i) ? MaxOddSym(s,i) : MaxEvenSym(s,i);
		if(CurMax > max)
			max = CurMax;
	}
	return max;
}

char str[MAXN];
int main(int argc,char *argv[])
{
	int MaxSymStr;

	//freopen( "D:\\Chengsq\\in.txt" , "r" ,stdin);
   // freopen( "D:\\Chengsq\\out.txt", "w" ,stdout);

	while(gets(str))
	{
		getchar();
		MaxSymStr = FindLongestSymStr(str);
		printf("%d\n",MaxSymStr);
	}
	return 0;
}


#endif

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值