poj-3349 Snowflake Snow Snowflakes

5 篇文章 0 订阅

Description

You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.

Input

The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.

Output

If all of the snowflakes are distinct, your program should print the message:
No two snowflakes are alike.
If there is a pair of possibly identical snow akes, your program should print the message:
Twin snowflakes found.

Sample Input

2
1 2 3 4 5 6
4 3 2 1 6 5

Sample Output

Twin snowflakes found.

    题意:一片雪花有六个枝,若枝的长度分别为1 2 3 4 5 6,那么它与枝长为4 3 2 1 6 5是同一种雪花,因为雪花为为圆形,1 2 3 4 5 6形成一周与4 3 2 1 6 5是相同的。输入一个n表示有n片雪花,之后是雪花枝的长度。

    该题建的哈希表为数组模拟的链表,表头为6个枝长度和对某值取余(因为sum值会非常大),在同种取余结果的表头中,查找相应情况,如果有顺逆时针存在一个符合输入顺序的情况就输出Twin snowflakes found.输入结束后所有雪花都没找到与其匹配的雪花,那么输出No two snowflakes are alike.

    为了减少结构体数组的大小,将每个节点里用一个大小为12的数组存一种情况,例如1 2 3 4 5 6,存在节点里为1 2 3 4 5 6 1 2 3 4 5 6,查找对比的时候从1-6开始进行6次比对,从12-7开始向前进行6次比对,遍历12种情况。

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>

using namespace std;

struct node
{
    int a[13];
    int next;
}d[1000000];
int snow[100000];
int arr[7],top;
void build(int head)
{
    int i;
    d[top].next=snow[head];
    for (i=1;i<=12;i++)
    {
        if(i<=6)
            d[top].a[i]=arr[i];
        else
            d[top].a[i]=arr[i-6];
    }
    snow[head]=top++;
}
int find(int head)
{
    int i=head,j,k;
    while(i!=0)
    {
        int flag=0;
        for (j=0;j<=5;j++)
        {
           for (k=1;k<=6;k++)
           {
               if(d[i].a[j+k]!=arr[k])
               {
                   flag++;break;
               }
           }
        }
        for (j=13;j>=8;j--)
        {
            for (k=1;k<=6;k++)
            {
                if(d[i].a[j-k]!=arr[k])
               {
                   flag++;break;
               }
            }
        }
        if(flag!=12) return 1;
        i=d[i].next;
    }
    return 0;
}
int main()
{
    int n,x,i;
    top=1;
    int flag=0;
    scanf("%d",&n);
    while (n--)
    {
        int sum=0;
        for (i=1;i<=6;i++)
        {
            scanf("%d",&arr[i]);
            sum +=  arr[i];
        }
        int head=sum%100001;
       if(snow[head]==0)
       {
           build(head);
       }
       else if(snow[head]!=0)
       {
           if(find(snow[head])==1)
            flag=1;
           else
                build(head);
       }
    }
    if(flag==0) printf("No two snowflakes are alike.\n");
    else printf("Twin snowflakes found.\n");
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值